Protel 99 SE
Training Manual

Schematic Capture
Software, documentation and related materials:
Copyright © 2001 Protel International Limited.

All rights reserved. Unauthorized duplication of the software, manual or related materials by any means, mechanical or electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited without the express written permissions of Protel International Limited.

Unauthorized duplication of this work may also be prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or imprisonment.

Protel and the Protel logo are registered trademarks of Protel International Limited. Design Explorer, SmartDoc, SmartTool, and SmartTeam and their logos are trademarks of Protel International Limited.

Microsoft, Microsoft Windows and Microsoft Access are registered trademarks of Microsoft Corporation. Orcad, Orcad Capture, Orcad Layout and SPECCTRA are registered trademarks of Cadence Design Systems Inc. AutoCAD is a registered trademark of AutoDesk Inc. HP-GL is a registered trademark of Hewlett Packard Corporation. PostScript is a registered trademark of Adobe Systems, Inc. All other brand or product names are trademarks of their respective owners.
6.1 Netlist Formats ...................................................................................................... 33
6.2 Net Identifier Scope ............................................................................................ 34
6.3 Other Netlist Creation Options ............................................................................ 34
6.4 Structure of a Netlist .......................................................................................... 35
7 Design Verification .................................................................................................. 36
  7.1 Setting up for an Electrical Rules Check ............................................................ 36
  7.2 Interpreting the Error Report and Error Markers .............................................. 38
  7.3 Exercises – Design Verification ........................................................................ 39
8 Reports .................................................................................................................. 40
  8.1 Library Editor Reports ....................................................................................... 40
  8.2 Schematic Editor Reports .................................................................................. 41
9 Process Containers ................................................................................................. 42
  9.1 Setting Up a Process Container ....................................................................... 42
  9.2 Executing Commands in Process Containers .................................................. 43
10 Printing ................................................................................................................ 44
  10.1 Printing In The Windows Environment ......................................................... 44
  10.2 Setting Up and Printing .................................................................................. 45
11 Short Cut Key Summary ....................................................................................... 47
1 The Schematic Editor Workspace

This section describes the Document Options and Preferences dialog boxes and their function in setting up the Schematic editor workspace. Settings in this dialog box are saved with the current schematic.

1.1 Schematic Editor Panel

The Schematic Editor Panel allows you to browse for components in libraries and for objects in open schematics.

1.1.1 Browsing the Schematic

- Choose Primitives in the field at the top of the Editor panel to browse for objects in the active schematic.
- You can browse by any of the object types available in the Schematic Editor.
- The bottom of the browser has three buttons: Text, Jump and Edit. Remember to select an item from the browse list before using these buttons.
- Press jump to go to the selected object, centring it in the window.
- Press Text to jump to the selected object and display a text editing dialog box when the object has a text field.
- Press Edit to jump to the selected object and display the objects attribute dialog box.
- Use the Update List button to refresh the browse list prior to browsing.
- The Status Bar provides information about the list item you have selected.
- Check the Partial Info box if wish to minimise the information in the component list box.
- Set the Browse mode to Primitives and click on Open All to open all the sheets in the project.

*Figure 1 Browsing primitives with the Schematic Editor Panel*
1.1.2 Exercises – Finding Placed Objects

1. Open the document Z80 Microprocessor.PRJ.

2. In the field at the top of the Browse section of the Editor panel, click on the down arrow and select the Primitives option.

3. Click on the Open All button at the bottom of the panel.

4. Select Parts in the list of object types. The Browse List will change to a list of Component Designators.

5. Click on the designator C10 to highlight it and click the Jump button. The system will zoom to the component C10.

6. Select Part Type in the list of object types. The Browse List will change to a list of component part types.

7. Click on the 10uF to highlight it and select the Edit button. The system will zoom to the 10uF capacitor C8 and display the Part Type dialog box so that you can change the capacitor value.
1.2 Document Options

The Document Options dialog box allows you set parameters relating individual schematic files. The settings in this dialog box are saved with the schematic file.

The Document Options dialog box is displayed by double clicking on the sheet border or by choosing the Design » Options menu command.

The tabs of the Document Options dialog box are described in the following sections.

1.2.1 Sheet Options Tab

The Sheet Options tab of the Document Options dialog box is shown in Figure 2. The options in each of the Sections are explained below:

![Document Options Dialog Box](image)

**Template Section** Displays the filename of the current template

**Options Section**

- **Orientation** Sets the sheet orientation to Landscape or Portrait
- **Title Block** When checked, a standard title block is attached to the sheet. The format of that title block is set using the drop down box next to this option.
- **Show Reference Zones** When checked, the sheet has a reference grid defined in its border.
- **Show Border** When checked the sheet border is displayed.
- **Show Template Graphics** When checked, any objects placed in the template file defined for the sheet will be displayed in the sheet. This is typically used to display a non-standard title block, in which case you would uncheck the Title Block option.
- **Border Color** Allows you to set the border colour
Sheet Color Allows you to set the background colour of the sheet.

Standard Style Section Allows you to select the size of the sheet from a number of standard sizes e.g. A4, A3.

Custom Style Section Allows you to define a custom sheet size and border. Use this option if you want a sheet size not covered in the Standard Style section.

Change System Font Button Allows you to change the font used to display pin numbers, pin names, port text, power port text and sheet border text.

Snap and Visible Grids

Grids Options allow you to set the size and turn on or off the Snap Grid and the Visible grid.

The Snap Grid forces the Mouse Click location to the closest snap grid point. The Snap Grid is set and can be turned on or off in the Document Options dialog box. It can also be turned on or off in the View Menu. (VG)

Note: The snap grid can be temporarily turned off while executing a command (i.e. when the cross hair is displayed) by holding the control key.

The Visible Grid displays a grid when turned on. This is independent of the Snap Grid. The Visible Grid is set and can be turned on or off in the Document Options dialog box. It can also be turned on or off in the View Menu. (VV)

Electrical Grid

Electrical Grid Option allows you to enable or disable and set the Grid Range for the Electrical Grid.

When the Electrical Grid is turned on and you are executing a command that supports the electrical grid, the cursor overrides the Snap Grid and “jumps” to key points on objects.

For example, if you are using the Place » Wire command and move the cursor to a certain distance within the Electrical Grid Range of a pin, the cursor will jump to the pin.

The Electrical Grid can be turned on or off and the Electrical Grid Range can be set in the Document Options dialog box. It can also be turned on or off in the View Menu (VE).
1.2.2 Organization Tab

The Organization Tab is used in conjunction with Special Strings to enter title block information into a sheet. A Special String operates as a link to a field in the Organization Tab. Text placed in the Organization Tab will display where the Special String is placed. Using special strings removes the need to accurately position title block text and allows for consistency in the use of font types and logos. There is a special string associated with every field of the Organization Tab as shown in Figure 3.

![Figure 3 Organization tab of the Document Option dialog box](image)

The Special Strings are listed below:

<table>
<thead>
<tr>
<th>Special String</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.TITLE</td>
<td>Sheet title</td>
</tr>
<tr>
<td>.DOCUMENTNUMBER</td>
<td>Drawing number</td>
</tr>
<tr>
<td>.REVISION</td>
<td>Revision</td>
</tr>
<tr>
<td>.SHEETNUMBER</td>
<td>Sheet number in the project</td>
</tr>
<tr>
<td>.SHEETTOTAL</td>
<td>Total number of sheets in the project</td>
</tr>
<tr>
<td>.ORGANIZATION</td>
<td>Organisation name</td>
</tr>
<tr>
<td>.ADDRESS1</td>
<td>Line of an address</td>
</tr>
<tr>
<td>.ADDRESS2</td>
<td>Line of an address</td>
</tr>
<tr>
<td>.ADDRESS3</td>
<td>Line of an address</td>
</tr>
<tr>
<td>.ADDRESS4</td>
<td>Line of an address</td>
</tr>
<tr>
<td>.DOC_FILE_NAME</td>
<td>Filename of the schematic sheet</td>
</tr>
<tr>
<td>.FILENAME_NO_PATH</td>
<td>Filename without the path</td>
</tr>
<tr>
<td>.TIME</td>
<td>Computer system time</td>
</tr>
<tr>
<td>.DATE</td>
<td>Computer system date</td>
</tr>
</tbody>
</table>

Table 1 Schematic Editor Special Strings
Figure 4 shows how Special Strings are entered in a title block. Text entered into a field in the Organisation Tab will display where the special string is placed. The properties of the Special Strings (i.e. font, colour) determine the properties of the text that is displayed.

You place Special Strings by selecting the **Place » Annotation** command then press the tab key. Clicking on the down arrow in the name field lists all the special strings. Click on the one required and place it.

![Figure 4 Special Strings in a title block](image)

### 1.3 Creating a User Defined Template

The procedure to create a template is described below:

1. In the Folder View, right click and select the **New** menu command to create a new schematic document and then open that document
2. Click on the **Design » Template** menu command
3. Select **Remove Current Template** and click on OK
4. Choose the **Design » Options** menu command
5. Click on the Sheet Options Tab
6. Locate Template File Name section

**Important!** The Template File Name section should read: **No Template File**

7. Un-mark the Title Block check box if it is marked.
8. Click on OK

**Tip!** Although the standard title block no longer appears on the page, it is important to understand that it has not been removed. It is hidden. You cannot remove the standard title block. Hiding it allows you to place your own title block in its place. If you do not hide it will be superimposed on the title block you create.

9. Select the sheet size in the Standard Style menu.
10. Zoom in to the bottom right corner of the page to start a custom title block.
11. Select the Place Line toolbar button from the Drawing Tools toolbar: a cross-hair will appear on the cursor
12. Draw the Title Block to your own requirements
13. Click on **Design » Options** and select the Sheet Options TAB
14. Select **Place » Annotation** or click on the Annotation toolbar button

15. Click on TAB key and define the font properties e.g. colour, thickness

16. Type .TITLE in the Text field and then click on OK (don’t forget the dot in front of the word)

17. Position the cursor in the appropriate region in your title block and left-click

You may or may not see the special string i.e. Title in the title block. If you do not see the Special String text in the title block do the following.

18. Select **Tools » Preferences** and select the Graphical Editing TAB

19. Mark the Convert Special Strings Check box

**Explanation!** If you do not mark the Convert Special Strings Checkbox, the information entered into the Organization Tab will be printed when you print your schematic. However it is reassuring to see it.

### Placing a Graphic into Your Template

1. Select the **Place » Drawing Tools » Graphic** menu command

2. Navigate to the graphic file you wish to use

3. Click On Open

4. Position cursor in the vicinity of your Title block

5. Click once to fix the top left of the image

6. Move cursor and click again to fix the bottom right of the image.

You can now define the size of the image to exactly fit the space allocated to it in the Title Block

1. Click on the image to put it in focus

2. Resize the image by manipulating its handles

You are now ready to save this sheet as a template

1. Select **File » Save Copy As**

2. Type the name in the Name field

3. Click the down arrow on the right of the Format field

4. Click on Schematic Template Binary (*.dot)

5. Click on Save

**Note!** The default location for Protel sheet templates is the Design Explorer 99 SE\Sch99 directory so it is suggested you create your template sheet in that directory.

The extension .DOT defines this document as a sheet template. This template can now be used for new or existing designs.

### 1.4 Updating Existing Templates

- Select **Design » Template » Update**
Update template is used when a template is modified and you need refresh the sheets, which use it.

- Select Design » Template » Set Template File Name
  This option removes the existing template and uses the one you choose.
- Select Design » Template » Remove Current Template
  This option removes the template (but retains the old sheet size from the old template)

### 1.5 Preferences

The Preferences dialog box allows you to set up parameters relating to the Schematic editor workspace. This dialog box is displayed using the Tools » Preferences menu command. Settings in this dialog box are saved in the Design Explorer environment and hence remain the same when you change active Schematic documents. The dialog box has three tabs. The options in each of the tabs are described below:

#### 1.5.1 Schematic Tab

**Pin Options Section**
These determine the position of the pin name and pin number on components.

**Multi-Part Suffix**
Determines how the designator of multi-part components is displayed.

Eg Alpha: U1:B    Numeric: U1:2

*Figure 5 Schematic tab of the Preferences dialog box*
**Orcad Load Options Section**

Copy Footprint From/To Determines which Orcad Part Field is used to load the Footprint field in Schematic editor components.

OrCAD Ports When this option is enabled, the length of all the Ports in a schematic design/project are re-sized to the OrCAD equivalent and the length of the Port is restricted from being manually edited.

**Default Power Object Names**

This allows you to set default net names for the power ports of style Power Ground, Signal Ground and Earth. Power ports with these styles do not display their net names. This option is provided to avoid the possibility of the net name defaulting to the name of the previously placed power port (E.g. which could possibly be VCC).

**Options Section**

Auto Junction When enabled, dots are automatically placed at “T junctions” of wires.

Drag Orthogonal When this option is enabled, dragging electrical objects will enforce wires to remain at 45/90 placement angle modes. Any angle or rubber banding wire placement is used if this option is disabled. The spacebar can be used at anytime while moving objects to toggle through the 45/90/any angle placement modes.

**Default Template File Section**

Specifies the default template (.DOT) file to be loaded when the File » New command is chosen. **Browse…** button Allows user to browse available template (.DOT) files.
1.5.2 Graphical Editing Tab

![Graphical Editing tab of the Preferences dialog box](image)

Figure 6 Graphical Editing tab of the Preferences dialog box

Options Section

**Clipboard Reference** When this option is enabled, you are prompted to select a reference point when copying and cutting selected objects to the clipboard.

**Add Template to Clipboard** When this option is enabled, the current sheet template including border, title block, and any additional graphics will be copied to the Windows clipboard when the Copy or Cut command is used. The sheet template is not added to the Advanced Schematic internal clipboard.

**Convert Special Strings** When this option is enabled, the special strings that have been placed onto the worksheet, for example, ".DATE", are converted to show their true representations, in this case the current system date would be displayed.

**Display Printer Fonts** When enabled, fonts that have been used on the screen will be substituted for the closest matching fonts that the current selected printer supports. For example, if a vector plotter is selected and true type fonts are used on the schematic sheet, all the true type fonts on the screen will be displayed with the closest matching font that the plotter supports. This option is disabled by default.

**Center of Object** If enabled, when you move or drag an object you will hold it by its reference point (for objects that have one) or its centre (for objects that don’t).

**Object's Electrical Hot Spot** If enabled, electrical objects will be held by their closest hot spot. (Centre of Object overrides when enabled as well)
**Auto Zoom** When enabled, the workspace is re-drawn with the object centred in the window (not active when using **Find** command or Jump from the Browser). For example, when using the **Window » Tile** command this option re-draws the whole sheet centred in the window.

**Single ‘\’ Negation** When enabled, a ‘\’ at the start of a text string cause the whole string to display with an over score (to signify active low status). Otherwise, the over score will only appear above the character preceded by the over score.

**Color Options Section**

**Selections** The default colour for selected objects can be changed by clicking in the colour box and choosing another colour from the Colour Selector dialog box. Advanced Schematic will display all the available colours that your graphics adapter supports.

**Grid Colour** The visible grid can be assigned a default colour. To assign new colour to the visible grid, click in the colour box to open the Colour Selector dialog box. Advanced Schematic will display all the available colours that your adapter supports.

**Auto Pan Options Section**

**Style**

<table>
<thead>
<tr>
<th>Auto Pan setting</th>
<th>Auto Pan Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto Pan Off</td>
<td>No auto panning</td>
</tr>
<tr>
<td>Auto Pan Fixed Jump Size</td>
<td>Continuous pan while the cursor touches the window edge</td>
</tr>
<tr>
<td>Auto Pan Re centre</td>
<td>Cursor position becomes centre of screen when it touches the window edge</td>
</tr>
</tbody>
</table>

*Table 2 Autopanning options*

**Speed** Allows you to set the Auto Pan speed.

**Cursor/Grid Options**

**Cursor Type** Three options are available for the physical (or sheet) cursor, a large 90-degree cross, small 90 degree cross or a 45-degree cross. The sheet cursor is displayed when executing commands.

**Visible Grid** The visible grid can be displayed as lines or dots.

**Undo/Redo Section**

**Undo Limit** This option allows the user to set the number of Undo/Redo levels. The default is 50. This allows the user to backtrack through (and restore) 50 individual operations.
1.5.3 Default Primitives Tab

This allows you to set the Default State of the properties of each object. Objects take on the property settings defined here when they are placed. Remember that you can change these property settings by pressing the TAB key before placing the object.

![Default Primitives tab](image)

*Figure 7 Default Primitives tab*
2 Libraries and Components

2.1 Browsing Libraries

Choose Libraries in the field at the top of the Editor panel to browse libraries.

- The Add / Remove button pops up the Change Library File List dialog box. From here you add or remove libraries to/from the library list. The added libraries appear in the Library list scroll box.

- Components contained in the selected library are listed in the box below the Filter field. The Filter allows you to control what Component names are listed. E.g. RES* will display only component names starting with RES.

- Clicking on the name of a component will display that component in the mini viewer at the bottom of the panel.

- Pressing the Browse button displays the Browse Libraries dialog box that includes a larger scale viewer.

- The Place button places the component currently selected. Double clicking on the name of a component also achieves this.

- The Edit button enables you to edit the part currently selected in the library list.

- NOTE - the part in the library is edited, not the part placed on your sheet.

- Pressing the edit button automatically switches you to the Library Editor, presenting the selected part for editing.

- The Find button is a powerful searching tool, allowing you to search through libraries for parts. Clicking this button pops up the Find Component dialog box.

- The editor panel can be widened to facilitate reading long library names by clicking and dragging on the inside edge of the editor panel.

*Figure 8 Browsing libraries with the Schematic Editor Panel*
2.2 Locating and Loading Libraries

The schematic libraries are stored within a set of Library Databases. Most of the Schematic Library Databases are manufacturer specific. There are a number of other special purpose databases e.g. a schematic-base PLD design. You can still access the components in the older .LIB format. Add these libraries to the list of available libraries in the normal manner.

Adding a database to the library list results in all libraries in that database being added to the library list.

Protel libraries are located in the \Program Files\Design Explorer 99 SE\Library\Sch\ folder.

1. Press the Add/Remove button in the Schematic Editor panel or select Design » Add/Remove Library
2. Navigate to the Schematic Libraries directory
3. Single click on a library to select it
4. Click on the Add button at bottom of dialog box. The library database you selected will now be listed in the Selected File list in the Dialog box.
5. Click OK when you have added the libraries you need.

![Change Library File List dialog box](image)
2.3 Locating Components

When you do not know which library a component is located in, use the Find button in the component browser or the Tools » Find Component menu command.

Tips For Finding Components:

- Searching by library reference is generally faster.
- Include the * wildcard before and after the library reference (as shown in image) as different manufacturers use different prefix and suffixes.
- If the reference comprises more than one word enclose each word between wildcards and separate the words with a single space.
- If your search does not produce results check that the path you stipulated is correct. Also, try searching for a component you know exists in a library to check that everything is correctly set.
- The search can be terminated as soon as an instance of the part is found by selecting the Stop button otherwise all libraries in which the part was found are listed. Libraries in which the part was found can then be added to the library list by selecting the Add to Library List button.

![Find Schematic Component dialog box](image)

Figure 10 Find Schematic Component dialog box
2.4 Placing Components

To place a component, double-click on it in the Components In Library list.

To edit the component properties before you place it, press the TAB key. The Edit Part dialog box will pop up.

To step through the fields in this dialog box, press the TAB key to step down, or SHIFT TAB to step up.

New text will overwrite text that is selected (white text on black).

If you set the component designator before placing the component, then subsequent components will be automatically designated with the next designator value.

**Tip!** You can copy a component already placed in the current sheet by selecting any component from the editor panel, moving the cursor with that component on it over the component to be copied. Press the INSERT key and the component to be copied will be on your cursor ready to be placed again.

**Note:** You can also use the **Place » Part** menu command if you know the precise name of a component. When you select this command, you are prompted for the name of the component. Once you type the component name in, the open libraries are searched and if the component is located, it becomes attached to the cursor for placement.

2.5 Exercises – Libraries and Components

**Locating and Loading Libraries**

1. **Open a schematic document to activate the Schematic Editor**
2. **Click the Add / Remove Button on the editor panel to display the Change Library File List dialog box.**
3. **Locate the \Design Explorer 99 SE\LIBRARY\Sch directory. This directory contains the library databases supplied with Advanced Schematic.**
4. **Scroll down through the library databases and locate and select and Add Motorola Databooks.ddb and Miscellaneous Devices.ddb**
5. **Click the OK button to close the dialog box.**
6. **The names of the libraries in these databases will appear in the Libraries list at the top of the editor panel.**
7. **Single click on any of the libraries in the Libraries section to have the library’s contents listed in box below the filter field section.**

**Locating Components Within an Open Library**

1. **Select the library Miscellaneous Devices.lib**
2. **Observe that the components in this library are now listed below the Filter field.**
3. **Scroll through the library.**
4. **Type res* into the mask field. Notice that only the resistor type components are listed.**
5. Try cr* in the mask field. The only component listed now is a crystal.

6. See if there are any DIP switches in the library. Hint - the wildcard * can be used more than once and can be used anywhere in the search string.

**Finding Components When Their Library Is Unknown**

1. Often you will want to locate a component but do not know which library it is in, or you may want to see what family types are available in the libraries. To search for components we use the Find button or the **Tools » Find Component**... menu command.

2. Click on the Find button, the Find Component dialog box will appear.

3. Now, find those parts that contain the string *74LS04* in their library reference.

4. Notice that a description of the highlighted library in the Found Libraries list appears in the Description field.

5. Click on a component in the component field. Observe that the description field now gives a description of the selected component.

6. Select a library with a 74LS04 in it.

7. Click the Add To Library List button. This library will now be in your library list.

8. Now see how you go finding a 4040. Remember you may need wildcards.

9. When you have located one, add its library to the library list.

10. Close the Find Component dialog box.
2.6 Assigning Designators

The Schematic editor offers two methods for assigning designators to components. These are described in this section.

2.6.1 Auto Incrementing Designators

When placing a component, if it does not have a default designator defined in the library, its designator will be assigned by incrementing the designator of the last component placed. (That is, provided the Permanent check box in the Default Primitives tab of the Preferences dialog box is not checked)

Hence you can use this auto incrementing to assign designators as you place them. You will have to change prefixes when required. I.e. when you change from placing resistors to capacitors. If you use this method it is possible to make errors such as repeating a designator.

2.6.2 Using Annotate to Assign Designators

The schematic editor provides an automated method of assigning designators. This is the Annotate command. This will take any component which has ‘?’ appended to its designator and allocates a unique designator to those parts.

The order in which designators are assigned is based on the components’ position on the sheet. The annotate dialog box allows you set one of four positional annotation options.

To run Annotate, choose the Tools » Annotate menu command. This displays the Annotate dialog box shown in the Figure 14 below.

The Annotate command also has the options to re-allocate all components in the project or to reset all designators to a prefix and a ‘’?’

You can also use Annotate to re-number the sheet numbers in your project.

Figure 11 Annotate dialog box
2.6.3 Advanced Annotation Options

The Advanced Options tab of the Annotate dialog box allows for user defined designator range and/or designator suffix. This tab lists each sheet in the project. Checking the check box next to the sheet name selects that sheet for advanced annotation. You set the minimum and maximum numbers for designators in the From and To columns and the designators suffix in the Suffix column.

![Annotate Options Window](image)

*Figure 12 Controlling the Annotation on a sheet-by-sheet basis*

2.6.4 Designators On Multi-Part Components

Multi-Part components (e.g., NAND Gates) have the designators of gates within the same components assigned in one of two ways:

- Alpha suffix (e.g., U1:A, U1:B etc)
- Numeric Suffix (e.g., U1:1, U1:2 etc)

You can change parts within a component using the Increment Part Number command in the Edit menu (EI) on the main toolbar. Select this command and then click on the part of interest. The next part in the component will be displayed.
2.6.5 Exercises – Drawing the Schematic

![Schematic for Exercise](image)

**Figure 13 Schematic for Exercise**

1. Create a new schematic document.
2. Set the template for your schematic to A4.dot using **Design > Template > Set Template File**.
3. Draw up the schematic shown in Figure 15.
4. Verify that the electrical grid is on and set to 10 and that the snap grip is on and set to 10 (OD) before placing any objects.
5. **NOTE** - Make sure the 4040 and the DIP switch are oriented correctly.
6. To flip a component, click and hold to ‘lift it’ from the sheet, then use the Y key to flip vertically and the X key to flip horizontally.
7. Set the Port I/O type is to Input.
8. The ground symbol is labelled GND.
9. Enter the necessary Document Information. Choose the **Design > Options** menu command. (DO)
10. Click on the **Organisation** tab and enter the following:

<table>
<thead>
<tr>
<th>Title</th>
<th>Serial Baud Clock</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sheet No</td>
<td>4</td>
</tr>
<tr>
<td>Sheet Total</td>
<td>8</td>
</tr>
</tbody>
</table>
3 Schematic Library Editor

The Schematic Library Editor is provided to create and modify schematic components and manage component libraries. The Schematic Library editor is very similar in operation to the Schematic Editor and shares the same graphical object types (but not the electrical objects). Also, the Schematic Library Editor has one additional object, the Pin that is used at points where wires connect to components.

Figure 14 Schematic Library Editor Workspace

The Schematic library editor has a Right Click Menu, a Drawing toolbar and IEE symbols toolbar (see figures below).

Figure 15 Library Editor command options
3.1 Library Editor Terminology

- **Object** - any individual item that can be placed in the Library editor workspace, for example a pin, line, arc, polygon, IEEE symbol etc.

Note: The IEEE range of symbols can be resized during placement. Press the ‘+’ and ‘-’ keys to enlarge and shrink the symbols as you place them.

- **Part** - a collection of graphical objects that represent one part of a multi-device component (e.g. one inverter in a 7404), or a library component in the case of a generic or singly packaged device (e.g. a resistor or a 80486 microprocessor).

- **Component** - either a single part (e.g. a resistor) or a set of parts that are packaged together (e.g. a 74HCT32).

- **Group** - refers to one or more library components that share a common component description and graphical image. For example a 7404, a 74LS04 and a 74ACT04 in the same library could all be in the same group. Sharing information makes the library more compact.

- **Hidden Pins** - these are pins that exist on the component, but do not need to be displayed. Typically they are power pins and will automatically be connected to a net with the same name as the pin name. This net does not need to be present on the schematic; one will be created, connecting all hidden pins with the same name. The pins will NOT automatically connect if they are visible on the schematic sheet (Un-hidden).
3.2 Library Editor Panel

The Schematic Library Editor panel provides a number of facilities for working with Schematic components. These are described below:

Components Section
This section lists all the components in the active library. The buttons below this aid in moving back and forth through the component list. The Mask field allows you to filter out components from the list.

Place Button
Allows you to place the current component in the Schematic Editor workspace.

Find Button
This displays the Find Schematic Component dialog box, which allows you to search libraries for a component.

Part Section
The Part buttons allow you to step through the parts of a multi-part component.

Group Section
This allows you to group together components that have the same graphics and description.

Update Schematics Button
The button updates any components placed in the Schematic editor that have been changed in the library editor.

Description Button
This displays the Component Text Fields dialog box. Note the four footprint fields. The required footprint is selected or set in the Schematic Editor. The footprint you choose in Schematic Editor must then match a component outline in your Advanced PCB design. The Description field is to provide a text description of the component’s function.

Pins Section
This lists the pins in the current component.

The Sort by Name check box allows you to list the pins ordered by their pin name.

Figure 16 Library Editor Panel
The Hidden Pins check box allows you to display all those pins that are defined as hidden. This does not change the actual pin hidden/unhidden status; rather it only displays the hidden pins in the Library Editor.

The Mode options control the graphical representation of your part. You can have three graphical “Views” of a component.

### 3.3 Component Text Fields

The Component Text Fields dialog box is where you enter textual information associated with a component. The dialog box is arranged into three tabs. The text fields in each of these tabs are described below.

**Designator tab**

<table>
<thead>
<tr>
<th>Fields</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Designator</td>
<td>Text that is placed in the designator when the component is placed</td>
</tr>
<tr>
<td>Sheet Part Filename</td>
<td>Use if you want to use sheet symbols as library parts</td>
</tr>
<tr>
<td>Description</td>
<td>A description of the component for use in the BOM report</td>
</tr>
<tr>
<td>Footprint1-4</td>
<td>This is the name of the PCB component to be used for this part type</td>
</tr>
</tbody>
</table>

*Table 3 Fields in the Designator Tab of the component description dialog*

**Library Fields Tab**

- Each library component has eight user-definable text fields.
• Use these for information in BOM reports
• Library text fields cannot be edited in the schematic editor, but can be viewed and included in reports.
• Typically Library Text Fields are used to store component information that does not change for each use of the part.

Figure 18 Library Fields tab of the Component Text Fields dialog box

Part Fields Names Tab
Use these for information that changes for each use of a component.

Figure 19 Part Field Names tab of the Component Text Fields dialog box
3.4 Modifying a Part Used In Your Schematic

- While in the Schematic editor select the part you wish to edit in the Components In Library list. NOTE - clicking on the part on the sheet will only work if its library is the active library.
- Click the Edit button in the Schematic Editor Panel. This will switch to the Library Editor, presenting the part for editing.
- Once you have finished editing, you must;
  - Save the library (using Save, Save As, or Save All)
  - Update the Schematic. Either pressing the Update Schematic button in the Library Editor Panel or the Design » Update Parts In Cache menu command in the Schematic Editor can do this.
- The schematic will now contain the updated part.

3.5 Creating a New Component

- Select Tools » New Component. You will be presented with an empty component sheet.
- Select Tools » Rename Component. Enter the new component name.
- Zoom in (PgUp) until you can see the grid.

Protel components generally have the top left of the component body located at co-ordinates 0,0. (Indicated by the two darker grid lines)

Create the graphical representation for the part.

- Place the pins for the part. It is important to orient pins so that the 'hot' end is away from the component body. When placing pins, the cursor will be on the 'cold' end of the pin. Use the Spacebar or X or Y to rotate the pin.
- Press tab to edit the pin properties before placing a pin. Remember to:
  1. Check that the number is correct
  2. Set the electrical type
  3. Set the hidden property if necessary
- To create a multi-part component, first create one part, including any hidden pins (power pins). Then copy the part to the clipboard using the Edit » Copy menu command (remember to select all first). Tools » New Part will then add a new part sheet under the same component name. Paste the part onto the sheet and update the pin information. Note that the Part field in the Panel will now show 2/2, meaning the second of two parts.
3.6 Creating a Project Library

This is performed from the Schematic Editor, using the Design » Make Project Library... menu command. This command creates a library document containing all the components in the project.

3.6.1 Exercises – Creating a Library and a Component

Creating a Project Library
1. Open the schematic called Serial Baud Clock.sch.
2. Create a project library.
3. Add the library to your library list.

Modifying a Part Used in Your Schematic
1. From the library list select the library you just added.
2. Click on the 4040 in the component list.
3. Click the Edit button. You will switch to the Library Editor.
4. In the Pins list, click on the pin RST. Change the pin name to RESET.
5. Update your schematic. Remember the sequence...
6. Verify that the schematic has been correctly updated.

Creating a New Component
1. In the Library Editor open the database Miscellaneous Devices.ddb.
2. Complete the component as per Figure 20.
3. When you add the component body you will need to send it to the back (Edit » Move menu).
4. When you are in the place pin mode, use the TAB key to edit the pin properties before placing the pins.
5. The power pins are pin 31 (GND) and pin 9 VCC. Make sure they are defined as Hidden.
6. Press the Description button. Enter U? as the default designator and DIP40 as footprint.
7. Save the library.

Figure 21 Example Component
4 Global Editing

Any edit that can be performed on an individual object can be applied to multiple objects of that type through global editing.

Figure 22 Dialog box with Global Editing section displayed

Global Editing is performed from the dialog box displayed when the Options button on the properties dialog box on any object is selected.

Editing can be applied to:

- The object
- All objects of the same type on the current sheet
- All objects of the same type throughout the currently opened sheets

There are basically three areas to a dialog box once the global button has been pressed. These are:

- The current Attributes (properties) of the part
- The Match By Attributes
- The Copy Attributes

The current Attributes area is on the left, and contains the current settings of the edited object’s properties. Pressing the Global button will then display the other two areas.
The **Match By Attributes** area is where the match is performed. If the **Current Attribute** column contains a text field, then the **Match by** column will also be a text field. If the **Current Attribute** column contains a check, then the **Match by** column will contain a choice field with the following options:

<table>
<thead>
<tr>
<th>Choice</th>
<th>Apply Global Edit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same</td>
<td>If attribute matches</td>
</tr>
<tr>
<td>Different</td>
<td>If attribute does not match</td>
</tr>
<tr>
<td>Any</td>
<td>Irrespective</td>
</tr>
</tbody>
</table>

The **Copy Attributes** area then determines what changes will be carried out.

If the new string is to totally replace the existing string for all matched objects, simply replace the braces with the new string.

Wild cards can be used anywhere in a text field, eg *PU*CL*.

Do not forget to set the Change Scope. The default will apply global editing changes to the current sheet only. The Change Matching Items In All Documents scope will apply changes to all currently opened sheets (irrespective of whether they are in the same project or not).

**Text Substitution**

You can achieve Global Edits on text by either of the following methods:

- If you wish to replace the entire contents of this field with a new value, remove the braces, "{" and "}" and enter the new value.
- Selective string substitutions can be performed, using the syntax `{oldtext=newtext}`. This means you can change a portion of the string "oldtext" to "newtext". In our example we changed the letter "D" for the string "Data". You can use multiple sets of brackets to define complex replacements. In this case the leftmost replacement is made, then the next on, etc. This is very powerful; you must take care because the first change can effect subsequent replacements, possibly generating an unexpected result.

You can further limit the replacement by typing `{!Text=text}` to make the changes case sensitive. In this case, "Text" becomes "text". Otherwise replacement is case insensitive by default.

### 4.1 Exercises – Global Editing

1. Open the document Z80 Microprocessor
2. Change the colour of a few wires to red.
3. Change the colour of all remaining wires in the project to green.
4. Check that changes have occurred; make sure that the red wires did not change.
5. Now change all wires back to blue.
6. Close the project and don’t save.

In the same project, perform a global edit to change the prefix ‘d’ in the data bus net names to ‘Data’.
5 Projects

Projects group together all schematic documents that define a PCB. A schematic document is part of a project if it has a corresponding Sheet Symbol on the project master sheet.

Constructing a Project

You can create a project from documents that already exist or you can create a project with empty sheets.

Steps:

1. Create a New Schematic document and give it a name
2. Select Place » Sheet Symbol command
3. Place as many sheet symbols onto the master sheet as required

Note! Each sheet symbol represents a sheet in the project.

4. Double-Click on a sheet symbol on the Master Sheet

The sheet symbol has two text properties. The first is the Filename. This must be the document name of the schematic that the sheet symbol represents. This schematic document should be located in the same folder as the master sheet. The second is the Name field. The name you enter should reflect the function of that schematic.

Sheet entries are added to the sheet symbol. Each sheet entry needs a matching port on the schematic.

5. Enter the document’s name in Sheet Symbol dialog box. (Note! Do not enter directory path)

6. Repeat procedure with all other Sheet Symbols on your master sheet.

The Master Sheet document you created will now be displayed in the Design Manager Explorer tab with a + plus symbol in front of it.

7. Click on the Plus symbol to expand the contents of the project.

5.1 Defining Projects the Easy Way

5.1.1 Top-Down Design

Use this to start a new project for which there are no existing schematics.

1. Create new schematic document
2. Place sheets symbols on sheet to create the project master sheet
3. Double-click on symbols and enter document names in Filename field
4. For each sheet symbol, select Design » Create Sheet from Symbol menu command

5.1.2 Bottom-Up Design

Use this to create a new project if the schematics exist.

1. Create a New schematic document as the master sheet
2. Click on **Design » Create Symbol from Sheet** command

Notice the Choose Document to Place dialog box appears

3. Select the Document you wish to connect to the symbol

A Sheet Symbol will now be floating on the cursor. The sheet symbol will have the correct file name and will have sheet entries to match each of the ports on the sub-sheet. Repeat this for each schematic to be added to the project.

### 5.1.3 Up/Down Hierarchy Button

1. Click on the Up/Down button

You will be prompted in the Status line to select a Port, a sheet entry, a sheet symbol or a sheet part.

2. Click on a sheet entry and you will zoom in on the matching port on the corresponding schematic.

3. Click on a sheet symbol or a sheet part and you will be switched to the corresponding schematic.

4. Click on a Port and you will be presented with the matching sheet entry on the Master sheet.

A hierarchical project is one that comprises two or more levels of sheets. There is no limit to the levels of hierarchy.

### 5.2 Types of Projects

There are three types of projects. The way the inter-sheet connections are defined differentiates the three types of Projects.

The method by which inter-sheet connections are established determines which Net Identifier Scope is selected with the Synchroniser or ERC.

**Intersheet Connections Using Global Port Names**

This uses port names to define inter-sheet connections. Nets on any sheet, which are connected to ports with the same name, will be connected on the PCB. With this type, use the Net Identifier Scope: Ports Global.

**Intersheet Connections Using Global Net Labels and Ports**

This uses port names and net label names to define inter-sheet connections. Nets on any sheet connected to ports or having net labels with the same name are connected on the PCB. If a net connected to a port also has a net label, its net name will be the name of the net label. With this type use the Net Identifier Scope: Net Labels and Ports Global.

**Intersheet Connections Using Ports to Sheet Entries**

This uses ports on sheets to take wires or buses up to sheet entries in corresponding sheet symbols on the project master sheet. Inter-sheet connections are defined by placing wires or buses between sheet entries on the project master sheet. With this type use the Net Identifier Scope: Sheet Symbol/Port Connections.
5.2.1 Special Cases:

**Below are special cases for projects**

1. You can define a project where multiple sheet symbols reference the same sheet.
   For example, a stereo amplifier design has identical circuits for the left and right channels. The multiple sheet symbols in the design will reference the same sheet.
   With this type of design, you must run the process Sch:ConvertComplexToSimple before running the Synchroniser.

2. You can build a schematic component to use as a sheet symbol. The pins of such a component are used like sheet entries with the pin names as sheet entry names. When you place this part, you enter the filename of the sheet it is to represent in the Sheet Path property.

**Summary**

If you are using sheet symbols with sheet entries, the net identifier scope must be *Sheet Symbol / Port Connections*.

If you are not, connectivity will be established via Ports and or Net labels, so you will use one of the other two net identifier scopes.

Net labels **DO NOT** connect to Ports of the same name.

5.3 Exercises – Building a Multisheet Project

1. Open the documents CPU Section.sch and Memory.sch

2. Create a new schematic document and re-name it as Test Project.prj, this is your project master sheet.

3. Place sheet symbols for the two schematics you just opened onto your project master sheet. *(Use Design » Create Symbol From Sheet)*

4. Respond YES to Reverse Input/Output Directions.
6 Netlists

A netlist is an ASCII file that contains the component and connectivity information defined in the schematic. The Netlist can used to transfer component and connectivity information to the Protel PCB Editor or to PCB Design packages from other vendors.

If you are using Protel 99 SE’s PCB editor to do the board layout there is a superior method of transferring design information between the schematic and the PCB (and from the PCB back to the schematic) – the design synchronizer. Using the synchronizer there is no need to create a netlist in the schematic and load that netlist into the PCB. Select Design » Update PCB to use the synchronizer.

![Netlist Creation dialog box](image)

Figure 23 Netlist Creation dialog box

6.1 Netlist Formats

There are almost forty different netlist formats available to the designer.

Formats include:

- Outputs suitable for other vendor’s PCB design tools
- EEsorf and Spice simulation tools
- PLD / FPGA compilers
- Protel netlist formats

There are two Protel netlist formats:

**Protel.** This format is supported by all versions of Protel Advanced PCB. It consists of two sections. The first section describes each component; the second section lists each net.
Protel 2. This format is only supported by Protel Advanced PCB version 2 and higher. It is an extension of the Protel format, but also includes simulation and PCB layout directives.

6.2 Net Identifier Scope

There are three net identifier scope options:

The first option is Net Labels and Ports Global. With this option all nets with the same net label will be connected together, on all sheets. Also, all ports with the same name will be connected, on all sheets. This option can be used for flat multi-sheet designs. It is not recommended for designs more than one level deep, as it would be difficult to trace a net up and down through the sheets.

The second option is Only Ports Global. With this option net labels are local to each sheet, they will not connect across sheets. All ports with the same name will be connected, on all sheets. This option is also intended for flat multi-sheet designs.

The third option is Sheet Symbol / Port Connections. This option makes inter-sheet connections only through sheet symbol entries and matching sub-sheet ports. Ports without a matching sheet entry will not be connected, even if a port with the same name exists on another sheet. Net labels are local to each sheet; they will not connect across sheets. This option can be used for flat designs as well as designs with multiple levels.

6.3 Other Netlist Creation Options

The Action After Netlist Creation pulldown allows the designer to switch directly to simulation or PLD programming software once the netlist has been generated. The program names are defined in the Run » Setup menu (down arrow at the left side of the menu).

Below this pulldown are four check boxes. The first allows the designer to generate a netlist for the current sheet only, handy if you wish to check the netlist for a single sheet.

The Append Sheet Number to Local Net Names check box will append the sheet number to each labelled net.

The Descend Into Sheet Parts check box will treat parts with a sub-sheet name entered into their Sheet Part field, as a sheet symbol (as discussed in the hierarchy section).

The Include Un-named Single Pin Nets check box will allow the designer to check through the netlist and verify that any single pin nets are acceptable.
### 6.4 Structure of a Netlist

The Standard Protel netlist has two sections.

- The first section describes each component. Each component description is enclosed in square brackets.
- The first line of the description is the component designator.
- The second line is the footprint that was assigned to that component (in the Part dialog box). There must be a matching component pattern in the PCB design file, which must have pin numbers that match the pin numbers of the component in the schematic.
- The third line is the information in the Part Type field.
- The second section describes each net. Each net is enclosed in rounded brackets.
- The first line is the name of the net. If the net has no net label then a name will be assigned during netlist creation.
- The following lines show each node in the net. The component designator and pin number will define each node (eg. U7-3, component U7, pin 3).
- The Protel 2 netlist has three sections. This format is an extension of the standard format, with additional fields in the component description section, additional component information in the netlist section (for simulation) and a third section that contains PCB layout directives.
- It is important for the designer to become familiar with the netlist format. Advanced Schematic will generate a netlist based on the information in the design, regardless of any logical or electrical violations. It is the designer's responsibility to ensure that the design itself is valid.
- An integral partner to netlist creation is the Electrical Rules Checker. This feature aids in design verification. It is covered in detail in the next section.

![Figure 25 Example of Protel Netlist Format](image-url)
7 Design Verification

The Electrical Rules Check feature ensures that any logical or drawing errors are found before Synchronisation is performed.

Figure 26 Setup Electrical Rules Check dialog box

7.1 Setting up for an Electrical Rules Check

- The Tools » ERC menu command will popup the Setup Electrical Rule Check dialog box. This dialog box is used to set up and execute the ERC process.

- Note the Rule Matrix tab in the dialog box shown in Figure 26. This matrix provides a mechanism to establish connectivity rules between pins and net identifiers. It defines the logical or electrical conditions that are reported as warnings or errors.

- For example an input pin connected to an input pin would not normally be regarded as an error condition, but connected output pins would. This is reflected in the table.

- Rules can be changed by clicking on the appropriate square in the matrix, causing it to cycle through the choices.
• The Suppress Warnings check box allows the designer to focus on the errors only.

• The Descend Into Sheet Parts check box is only required if you are using parts as sheet symbols (as described in the Hierarchy section).

• The Net Identifier Scope must be appropriate for the model of hierarchy chosen. (Covered in the Netlist and Hierarchy sections)

• “No connection error” messages can be suppressed by placing no ERC markers on pins and net identifiers (Place » Directives » No ERC command or the Suppress No-Connection Error Message button on the wiring toolbar).

• “No connection error” messages for all floating input pins can be suppressed via the Floating Input Pins check box.
7.2 Interpreting the Error Report and Error Markers

- Running the ERC will result in error markers being placed on all points which cause a warning (if enabled) or an error. An error report will be presented in the text editor.

- Error markers that are placed on the sheet by the ERC can be jumped to either by:
  - Selecting the Error Marker filter in the browse section of the editor panel and then selecting each error marker and jumping to it. As you select each error marker, details of the error are displayed in the status field.
  - Selecting **Edit » Jump » Jump to Error Marker (JE).**

- Subsequent passes of the ERC will remove error markers once the error conditions have been corrected.

- For each error and warning the error report may include:
  1. The sheet file name, e.g. CPU.SCH
  2. The XY co-ordinate, e.g. At (450,360)
  3. The component reference and pin number, e.g. U1-4
  4. The net label, e.g. Net D7

- It is important to examine each warning and error and either mark them with no ERC markers or resolve them. This should always be done prior to netlist generation.

- The **Edit » Select » Net** command can help when you are attempting to verify a particular net.
7.3 Exercises – Design Verification

1. Open the Z80 Microprocessor.prj in the training directory
2. Start the Electrical Rules Check process using **Tools » ERC**.
3. Verify that the Net Identifier Scope is set to Sheet Symbol / Port Connections in the Set Electrical Rules dialog box.
4. Click OK to start the process. The log file will be displayed in the Text Editor once the ERC has run.
5. Resolve the errors. Some tips:
   Examine each of the objects associated with the error.
   - Click on wires and buses to bring them into focus and verify that they connect correctly to pins and ports. (Not overlapping)
   - Use the **Edit » Select » Net** command to verify net to wire association. Click on the top of the net label - if the association is good, both the net label and the wire will become selected.
   - Errors with input pins are often due to problems with their source. If the input looks OK, trace the signal back to the source (output pin / port).
   - Use the large up and down arrows on the main toolbar to trace nets / buses through the design. You can click on either the sheet symbol or the sheet entry when descending into sheets.
   - Simple problems often create a multitude of errors.
   Re-run the ERC to remove error markers after you correct a problem.
   When you have a clean ERC report, save the project.
8 Reports

8.1 Library Editor Reports

There are three reports that can be generated in the Library Editor. All have the syntax
Library_Filename.extension:

1. The Reports » Component command generates a .CMP file that includes the component
name; part count; components in the same group; details of each part; details of all pins.
This report can be used to verify that the component has been correctly constructed.

2. The Reports » Library command generates a .REP file (plus a CSV version), which
includes a component count; the name and description of each component in the library.
This report can be used to create a listing of the components in a library; handy if you need
a printed reference of a library.

3. The Reports » Component Rule Check command pops up the Component Rule Check
dialog box (refer to Figure 26). These allow you to test for:

   • Duplicate component names and pins;
   • Missing description,
   • Missing footprint,
   • Missing default designators,
   • Missing pin name
   • Missing pin number
   • Missing pins in sequence

This generates an .ERR report, which reports on all components in the active library. This
report can be used to aid in library verification and library management.

Figure 28 Library Component Rule Check dialog box
8.2 Schematic Editor Reports

The following commands generate reports as described below:

1. The Reports » Bill of Material command launches the BOM Wizard. This displays a number of forms in which you can select the fields to be included, headings for the fields and the format of the output.

2. The Reports » Design Hierarchy command generates a .$$$ file which includes a list of all the files (including their full path) that make up the project. The .$$$ report allows the designer to quickly verify the project file structure.

3. The Reports » Cross Reference command generates a .XRF file that includes a list of each of the components in the project, their part type and the file name (including path) of the sheet they are on.
   - The .XRF report provides a means of cross-referencing each part with its sheet file name.

4. The Reports » Netlist Compare command generates a .REP file that includes: a listing of all matched nets and their quantity; a listing of partially matched nets, their quantity and information about their differences; the total number of extra nets in each netlist; the total number of nets in each netlist.
   - The .REP file allows the designer to compare two netlists, which can be useful in confirming that design changes have been successfully translated into a new netlist.
9 Process Containers

Process Containers enable you to execute a command with a defined set of parameters. Also, any files resulting from a command run from a process container become part of the project. A Process Container is a schematic editor object, which is placed on one of the sheets in the project, usually the project master sheet.

An example of their use is for netlisting. When you execute the Design » Create Netlist command, the Netlist Creation dialog box is displayed from which you can select the various netlisting options. Depending on which option you choose it is possible to create vastly different netlists from the same project.

To ensure that the netlist for a project is created with the same options every time is to execute it using a Process Container.

9.1 Setting Up a Process Container

To set up a Process Container, you select the Place » Process Container menu command and then press the tab key to display the Process Container dialog box.

To assign a command to the Process Container, press the Browse button and then choose the Server and Process for that command from the Process Browser dialog box that this button displays.

In the Instance Name field, you enter a unique name for this process container. This will enable you to identify this process container from others.

To set the parameters for the command, press the Configure button. This executes the command. If the command displays a dialog box, any options that you set will be stored as parameters in the process container.

Once you have configured the Process Container, you can view and edit the parameters by pressing the Change button.

Pressing the Execute button will execute the command in the process container using the specified parameters.

Figure 29 Process Container Properties dialog box
9.2 Executing Commands in Process Containers

To execute a process container, select the Tools » Process Containers » Run menu command. This displays a list of the Process Containers on the current sheet. Double-click on the name of the process container you want to execute. If a process container is in focus when you select the Tools » Process Containers » Run command, that process container will execute.

The Tools » Process Containers » Run All menu command will execute all process containers on the current sheet.
10 Printing

10.1 Printing In The Windows Environment

1. Microsoft Windows manages the printing (or plotting) process, providing the interface between the Protel software and the printer.

2. Printing in Windows is a complex process, which includes; the application software, the printer driver, MS Windows, Print Manager (if enabled), the PC hardware, the printer cable and of course, the printer.

3. The printer driver may be a generic Windows product, or supplied by the printer manufacturer.

4. Printers and plotters are installed and assigned to a port in the Windows Control Panel (Printers).

5. In the Control Panel, select the Printers icon, and then use the Add button to select the appropriate printing device (you may be requested to provide one of the Windows disks). Then use the Connect button to assign the port.

![Schematic Printer Setup dialog box](Figure 30 Schematic Printer Setup dialog box)
10.2 Setting Up and Printing

- The File » Setup Printer command pops up the Setup Printer dialog box.
- The Select Printer option allows you to choose a printer.
- The Batch Type option selects between the current sheet (or component in the Library Editor) and all open sheets (for all open projects). The All Documents option in the Library Editor will print all components in the active library (not other open libraries).
- The results of the Colour Mode choice (colour or monochrome) will depend on your printer. PostScript or HP-PCL devices will print greyscale representations of colour. Select monochrome for low-resolution dot matrix printers and single pen plotters.
- Margins are completely user selectable, limited only by the no-print zones of your printer.
- The Scale range is .001% to 400%. The Scale To Fit Page option maximise the size of the print on the page. If this option is enabled, the margins can be set to zero. The print will be maximised within the limits of the device no-print zones, bounded only by the aspect ratio of sheet relative to that of the page.
- If the print does not fit on the page, it will be tiled over a number of pages. The pages are tiled so that the margin requirements for each corner are met on at least one page. It is often possible to reduce the number of sheets required to tile a print by changing the paper orientation in the printer setup.
- Press the Setup button to pop up the printer setup dialog box. This dialog box will be specific for the printer (which you have selected in the Select Printer pulldown). It will include device specific choices such as; orientation, paper tray, pen colour, pen thickness etc.
- Use the preview button to see how the print will be laid on the page.
- The Network button provides access to network printer resources, if available.
- Use the Print button here or the File » Print command to print the design.
ERC Exercise Answers

MEMORY sheet - the net label on the data bus is missing a dot. It should be D[0..7]
PPI sheet - the net label on the data bus should be A[0..15], not A[1..15].
CPUCLK sheet - the net does not connect to a port.
POWER sheet - duplicate component designators, one should be C4, the other C5.
CPU sheet - the reset line has two net labels, one RESET, the other RST.
CPU sheet - the net label RESET is not connected to its net.
CPU sheet - the address bus line A[0..15] extends under the port and does not connect.
### 11 Short Cut Key Summary

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+BACKSPACE</td>
<td>Redo</td>
</tr>
<tr>
<td>ALT+BACKSPACE</td>
<td>Undo</td>
</tr>
<tr>
<td>PgUp</td>
<td>Zoom In</td>
</tr>
<tr>
<td>CTRL+PgDn</td>
<td>Zoom All</td>
</tr>
<tr>
<td>PgDn</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>END</td>
<td>Redraw</td>
</tr>
<tr>
<td>CTRL+HOME</td>
<td>Jump to Origin</td>
</tr>
<tr>
<td>HOME</td>
<td>Pan</td>
</tr>
<tr>
<td>SHIFT+Insert</td>
<td>Paste</td>
</tr>
<tr>
<td>CTRL+Insert</td>
<td>Copy</td>
</tr>
<tr>
<td>SHIFT+Delete</td>
<td>Cut</td>
</tr>
<tr>
<td>CTRL+Delete</td>
<td>Clear</td>
</tr>
<tr>
<td>DELETE</td>
<td>Delete focused object</td>
</tr>
<tr>
<td>CTRL+F</td>
<td>Find Text</td>
</tr>
<tr>
<td>CTRL+G</td>
<td>Find And Replace Text</td>
</tr>
<tr>
<td>F1</td>
<td>Run Online Help</td>
</tr>
<tr>
<td>F3</td>
<td>Find next text</td>
</tr>
<tr>
<td>SHIFT+F4</td>
<td>Tile all open documents</td>
</tr>
<tr>
<td>SHIFT+F5</td>
<td>Cascade all open documents</td>
</tr>
<tr>
<td>SHIFT+CTRL+Left_Click</td>
<td>Move single object</td>
</tr>
<tr>
<td>SHIFT+Left_Click</td>
<td>Toggle single object selection</td>
</tr>
<tr>
<td>CTRL+Left_Click, then release CTRL</td>
<td>Drag single object</td>
</tr>
<tr>
<td>CTRL+Left_Hold_Down, then release CTRL</td>
<td>Drag single object</td>
</tr>
<tr>
<td>Hold CTRL while moving or dragging</td>
<td>Disable snap grid</td>
</tr>
<tr>
<td>Hold ALT while moving or dragging</td>
<td>Constrain movement to vertical direction</td>
</tr>
<tr>
<td>Hold SHIFT+ALT while moving or dragging</td>
<td>Constrain movement to horizontal direction</td>
</tr>
<tr>
<td>Left_Click</td>
<td>Focus object</td>
</tr>
<tr>
<td>Left_Dbl_Click</td>
<td>Change object</td>
</tr>
<tr>
<td>Left_Hold_Down</td>
<td>Move object / move selection</td>
</tr>
</tbody>
</table>
## Pop Up Menus

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>Select</td>
</tr>
<tr>
<td>X</td>
<td>De-Select</td>
</tr>
<tr>
<td>M</td>
<td>Move</td>
</tr>
<tr>
<td>A</td>
<td>Align</td>
</tr>
<tr>
<td>J</td>
<td>Jump</td>
</tr>
<tr>
<td>L</td>
<td>Location Marks</td>
</tr>
<tr>
<td>B</td>
<td>Toolbars</td>
</tr>
<tr>
<td>Z</td>
<td>Zoom</td>
</tr>
</tbody>
</table>