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1 Introduction to the Design Explorer
Design Explorer is an integrated environment for Electronics design. It provides tools for all
tasks from schematic entry, simulation through to PCB design. It also provides the ability to
manage complete design projects involving design teams. In addition, the environment can be
customised to meet a wide variety of user requirements.

2 Smart Technology
Protel 99 is built on Protel’s Smart integration technologies i.e. SmartTool, SmartDoc and
SmartTeam.
•

SmartTool is the Client/Server technology that brings all design tools together into a
single user interface. These tools include the Schematic Editor, Mixed Signal Circuit
Simulator, PLD Compiler, PCB Placement and Routing and PCB Signal Integrity
Analysis. SmartTool technology also integrates Active Doc compliant editors. These
include Microsoft Word, Microsoft Excel and AutoCAD.

•

SmartDoc technology resolves the task of document management. With SmartDoc all the
Design documents associated with your project (eg Schematics, PCB’s, Libraries, BOM
Reports) are arranged together into a Design.

•

SmartTeam technology allows you to control how users get access to documents in your
Design project.

Protel 99 brings these three technologies together in the Design Explorer
Design Explorer configures the interface to suit the document you are working on. For
example if you open a Schematic sheet, appropriate toolbars, menus and shortcut keys are
activated. This feature means that you can switch from routing a PCB to calculating
manufacturing costs in a spreadsheet to running a transient circuit analysis without having to
change editors: simply click on the next document you wish to work on.

3 How to Work in Design Explorer
3.1 The ‘Design’ Concept
Design Explorer allows you to access all documents related to a design via its user interface.
Design Explorer provides the option of either storing all documents related to a Design in a
single database file or to store the documents in the Windows File System. Regardless of the
storage method, the user interface is the same. When you first create a new Design, you are
given the option of choosing the Design Storage Type.
If you choose the storage method of a single database file, all documents that make up your
design, such as schematics, PCB’s, BOM reports and even AutoCAD drawings are stored in
this design database file. This file uses the MS Access Database format and has the default
extension of ‘.DDB’.
Documents in the Design can be arranged into folders in a manner similar to arranging files in
Windows Explorer directories.
Design Explorer Environment
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Files can be included into a database using import. Documents in a database can be exported
as files.
With a Windows File System storage method design, all the documents and folders are
displayed in Windows Explorer.

Figure 1 Windows Explorer view of a Windows File System design

With a Database storage method design, only the .ddb file from a Design is displayed in
Windows Explorer.

Figure 2 Windows Explorer view of a Database design
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3.2 Overview of the Environment
The Design Explorer environment consists of 2 main elements: the Design Manager Panel and
the Design Window. The Design Window can display in Folder View or in Editor View as
shown. These views are described below:
•

Folder View This view displays icons representing the documents or folders within the
current folder. Double-click on these icons to display the Editor View of a document or the
Folder View of a folder.

•

Editor View This view displays the document in its editor. E.g. PCB Editor for a PCB
document, Schematic Editor for a schematic document.

The Design Manager Panel displays the Explorer tab when the Design Window displays a
Folder View. The Explorer tab allows you navigate into Databases currently open in Design
Explorer. It operates in the same manner as the All Folders panel the Windows Explorer.
When the Design Window displays an Editor View of a document, the Design Manager has an
additional tab; the Browse tab for whichever editor is currently active. Clicking on the Browse
tab will display the Editor Panel for that editor.

Explorer Tab

Icons representing
documents and folders

Design Manager Panel

Design Window in Folder View

Figure 3 Design Manager and Design Window in Folder View
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Figure 4 Design Manager and Design Window in Editor View

Folders and documents that are open are allocated a Tab at the top of the Design Window.

Figure 5 Design Window Tabs

Note: When an existing Design is opened, documents in that design that were active in editors
when the design was last opened, will again be active. To avoid this, hold the Ctrl key while
opening the design.
Opening an Existing Design
The database Z80 Microprocessor.ddb is located in the Examples folder of the Design
Explorer directory.
Follow the steps below to locate and open the database and in the process learn to use the
Open Design Database dialog box.
Steps:
1. Select the File » Open menu to display the Open Design Database dialog box.
4
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We now need to navigate to the Examples directory the Design Explorer 99 SE directory.
2. Locate Z80 Microprocessor.ddb and double-click on it
The Design will now be listed in the Navigation Tree on the left side of the screen and will
have a + sign next to it.
3. Click on the + sign to expand its contents
4. Click on any other plus signs to expand folder contents
You will notice that you now have a number of – signs in the directory tree
5. Click on the – signs to contract the folders

3.3 Explorer Panel
The Explorer Panel is displayed by clicking on the Explorer tab of the Design Manager.
•

To expand a branch and view lower level folders, click on the Plus sign to the left of the
folder icons.

•

When a folder is expanded the Plus sign turns to a minus sign. Clicking the minus sign
will collapse the branch again.

•

Click and drag to move folders in the Navigation Pane to another location - even to
another Design Database.

•

icon in the Explorer Panel and the contents of the folder will
Click on a Folder
appear in the Design Window. A Tab for that folder will be displayed at the top of the
Design Window.

•

icon in the Explorer Panel to activate its editor: e.g. click on
Click on a document
a schematic document in the navigation tree and it will be displayed in the Schematic
Editor.

Move, Copy or create Short Cuts to Folders Via Design Explorer Panel

Design Explorer Environment

•

Right mouse click and hold on a folder

•

Drag and drop onto another folder

•

Release the mouse button to display the Move, Copy
or Create Shortcut dialog box

•

Select from the options
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3.4 Design Window
3.4.1

Folder View and Editor View

The Design Window has a Folder view and multiple Editor views. The Folder View displays
the contents of folders. Folder contents can be displayed as large icons, small icons, as a list
or as a detailed list. Below is the folder view of the Z80 Microprocessor design displayed as
large icons.

Figure 6 Folder View of Z80 Microprocessor .Ddb

3.4.2

Document Selection Options in the Folder View

Document and Folder icons can be selected for Click and Drag operations. One or more icons
can be selected by any of the options below:
•

Click on an icon to select it.

•

Shift+Click on an icon to select it and all other icons to the right of it in a particular row
(Note! If you use this option when a icon is already selected, only the icons between the
icon you Shift-Click on and the already selected icon will be selected.)

•

Ctrl+Click on an icon to add it to the selected icons

•

Ctrl+Click on an icon already selected to de-select it

6
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3.5 Right Click Menus in Folder View
Right Click on a Folder

1. Right click on a folder or document icon in the
Design Window to display this menu.
2. Select options from the menu

Right Click Elsewhere

Right click on a vacant space in the Design
Window to display this menu.
This second menu enables you to create new
documents or folders, import documents, link to
external documents, paste from the clipboard and
choose a viewing mode.

Click and Hold Menu

1. Click and hold on a document or a folder icon etc.
2. Drag it onto a destination folder
3. Release the right mouse button and choose from the
Menu options that display (see left)

Design Explorer Environment
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3.6 Right-Click Menu on Design Window Tabs

•

Right click on a Document or Folder Tab at the top of the Design Window.

•

Select Close from the menu.

Note! If you right click a DDB (include graphic) Folder Tab, the database will be removed
from the navigation tree.
•

Right Click on any Document or Folder Tab at the top of the Design Window pane

•

Click on Tile All

Notice that all the opened documents and folders are displayed in multiple screens.
Note! The number of opened documents and folders determines the number of regions.
•

Right-click on any one of the Tabs in the tiled display.

•

Choose Merge All

Notice that you have converted a split screen back to a single view.
•

Position the cursor at the point where two regions of a split screen meet ( a double-headed
arrow will display)

•

Click and drag to re-size

8
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3.7 Document Finder
The document finder is invoked by selecting F3 or Ctrl + F.
This allows you to search the current design, your hard disk or your network for documents.

Design Explorer Environment
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4 Document Editor Overview
To display a document in its editor, click on a document icon in the Explorer Panel or doubleclick in a Folder View in the Design Window, and the document will be opened in the
appropriate editor.
Note! When you create a new document in a Design you are required to select a document
type e.g. Schematic, PCB.
The document type you select determines which Editor is assigned to the document.
The following sections describe the various elements in editor view.
Open or create a document and the appropriate editor is activated. The sections below describe
the various elements in the user interface of Design Explorer editors.

Toolbar

Menu

Floating
Toolbar
Pop-up
Menu

Editor Panel

Status Bar

Figure 7 Schematic Editor

4.1 Menus
•

Protel menus are standard Windows menus.

•

Menus are consistent across all editors in the Design Explorer.

•

Standard operations e.g. opening, saving, cut, paste etc are consistent across editors

•

Double-click on an empty space on the menu bar to edit it.

10
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4.2 Shortcut Keys and Pop-Up Menus
•

Menu commands can also be accessed using Shortcut Keys. The underlined letter (e.g.
press F for the File menu) indicates the Shortcut key for a menu command.

•

Special shortcut keys give direct access to menus in the graphical editors e.g. pressing F in
the Schematic Editor will pop up the File menu, pressing T will pop the Tools menu.

4.3 Toolbars
•

Toolbars can be fixed to any side of the workspace or they can be floated (see floating
toolbar in figure above)

•

Click and drag to move a toolbar (the cursor must be within the toolbar but not actually on
a button)

•

New toolbars can be created and existing toolbars edited.

•

Multiple toolbars can be active

4.4 Design Manager
•

The Design Explorer and the currently active editor panel are combined into one panel
called the Design Manager.

•

The Design Manager panel can be position on the left or right side of screen.

•

The Browse tab in the Design Manager indicates which editor is currently in use i.e. if you
are editing a Schematic sheet, the tab will say Browse Sch.

•

Clicking on document icon in the explorer makes the document active.

•

When a document is active it is allocated a Tab at the top of the Design Panel

•

Click on the Explorer Tab or the Active Editor TAB in the Design Manager to activate it –
you cannot activate both at the same time.

•

Clicking and dragging on the side that touches the Design Window can adjust the width of
the Design Manager.

4.5 Status Bar
•

The Status bar is used to display information to the user.

•

•

The Status bar consists of three display fields whose positions are indicated by arrows in
the Status Bar. These fields are:
1. Cursor position
2. Prompt
3. Options
The Prompt and Options fields can be re-sized clicking and dragging on the arrows.

•

The Status Bar is turned on and off using the menu command View » Status Bar.

•

The Status Bar can be positioned at the top or the bottom of the Design by a click and drag
operation.

Design Explorer Environment
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4.6 Command Status Bar
•

The Command Status Bar displays the name and action of the command currently being
executed.

•

When turned on, the Command Status Bar is located below the Status Bar.

•

The Status Bar is toggled on and off using the menu command View » Command Status.

•

Most users choose to turn off the Command Status Bar.

4.7 Tool Tips
•

Provide a brief description of how to use a particular function.

•

Position the cursor over a toolbar button and leave it stationary for about a second and the
tool tip will appear.

•

Tool Tips are turned on or off in the System-Preferences dialog box that displays when the
Preferences command in the System menu (down arrow at the left side of the menu).

4.8 Right Mouse Pop-up Menu
Clicking the Right Mouse button in an Editor pops up a menu of commands at the current
cursor position.

Figure 8 Right Mouse Menu

4.9 Dialog Boxes
Dialog boxes are used to set the parameters for various commands.
To move from one field to another in a dialog box press the TAB key or use the mouse.
SHIFT TAB takes you in the reverse direction.
Most fields will have an underlined character associated with them that can be pressed (in
combination with the ALT key) as an alternative to a mouse click.
When a field is highlighted, typing on the keyboard can overwrite it.
12
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5 Design Explorer System Menu
The System Menu provides commands for configuring the
Design Explorer. You can access these commands by
located on the
clicking on the down pointing arrow
left-hand side of the Menu. The System menu is always
accessible in Design Explorer.
The following sections describe the entries in the System
menu.

5.1

Servers

The menu item is provided to enable the management of servers. Under normal usage of
editors in Design Explorer, you should not need to install or remove servers. Installation and
removal is performed from the EDA Servers dialog box shown below which is displayed by
selecting the Servers command from the System menu.
To install a server, Right Click and then choose Install. This displays the EDA Servers dialog
box from which you locate and select the server install file (servername.ins). This would
normally be located in the directory where all the files for that server are located.
To remove a server, you click on the icon of the server to removed, Right Click and choose
Stop if the server is running and then Right Click and choose Remove. When a server is
removed, any resources associated with that server are deleted.

Figure 9 EDA Servers dialog box

Design Explorer Environment
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5.2

Customise

The menu enables the management of resources associated with the current editor. For more
on this, refer to the sub-section on Customisation.

5.3

System Preferences

Various global system preferences can be set for Design Explorer, including toolbar tool tip
status, tip of the day status and file backup options.
To set Design Explorer preferences select Preferences from the System menu. This will open
the System Preferences dialog box shown in figure 8.

Figure 10 Preferences Dialog Box

5.4

Design Utilities

Selecting the Design Utilities command displays the Compact & Repair dialog box, which has
tabs as, described below.
Compact Tab
As you create and remove documents from a design database it can become fragmented and
use disk space inefficiently. “Compacting” a design database will recover any unused space
within the database.
Check the Perform Compact after closing design check box to ensure that databases are
compacted after editing.

14
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Figure 11 Compact Tab Dialog Box

Repair Tab
If a design database behaves unpredictably it may have become damaged. If you suspect that a
design database has become damaged use the Repair feature to restore it.
Note - the design database must be closed before it can be repaired.

Figure 12 Repair Tab Dialog Box

Design Explorer Environment
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5.5 Auto Save
When Auto Save is invoked, any documents open in Design Explorer are exported to files.
The document name and its editor determine the name of the exported file. The extension is
BK + a number indicating which back up file it is.
(E.g. Z80 microprocessor_PCB.BK0)
Configure Auto Save by selecting the Preferences command in the System menu (the down
arrow at the left-hand end on the pull down menu). This displays the System Preferences
dialog box. Pressing the AutoSave Settings button on this dialog box displays the Auto Save
dialog box.

Figure 13 Auto Save dialog box

The Auto Save options are described below:
Enable when checked all documents open in Design Explorer will be auto saved.
Number allows you to set the number of back up files to be created before the first Backup
file is overwritten.
Time Interval allows you to set the time interval between auto saves.
Use backup folder Allows you to nominate where the back up files are saved. If unchecked,
back up files are saves in the directory where the original file is located.
Information provides a complete description of the Auto Save function. Click on the Next>>
or <<Previous buttons to move between pages.
Files saved by Auto Save use the file-name followed by an underscore, file type and back up
extension number as shown in the figures below. Auto Save overwrites the oldest auto saved
file. When restoring a file from the auto save directory, choose the auto save file with the most
recent modified time.

16
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Figure 14 Autosaved files

Figure 15 Autosaved Files ( later)
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6 Designs and Documents
A Design is a set of Documents, possibly arranged within Folders. Using the Windows
Explorer analogy, a Design is the top level of a directory tree (one below the root). A Design
could comprise the schematic and PCB documents for a particular PCB but it could also
comprise schematics, PCB’s, AutoCAD drawings, parts databases and Word documents for a
design project involving many PCB’s and other associated mechanical designs.
To create a new design:
1. From the Main Menu select File » New Design to display the New Design Database dialog
box.
2. Choose the Design Storage Type from either MS Access Database or Windows Files
System.
3. Enter the Database name in the Database File Name field.
4. Click on the Browse button and navigate to desired location if you wish to relocate the
database
5. Click on Password Tab
Note! The default setting is to have no password protection. It is therefore not necessary to
click on Password Tab if you do not require password protection.

18
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6.1

Creating a New Document In a Design

To create a new document:
1. Open the desired folder
2. Right-Click on an empty space in the Design Window (a menu will display)
3. Choose New from the list of menu options to display a collection of document types.

4. Select the required document type (e.g. Schematic document)
5. Click OK
6. An icon for the new document will appear in the Design Window e.g.
Tip! The installed editors determine the range of document types available.
In Design Explorer any document that is created and edited by an OLE server registered on
your PC will appear in the New Document dialog box.
If you activate the “Show All Document Kinds” feature all the available editors will be
displayed.

6.2

Renaming Documents

To rename a document:
1. Single click the document icon in the Design Window
2. Right click on the icon and select Rename or from the menu, select Edit » Rename
An icon with highlighted text will appear, ready for you to type in a new name.

Design Explorer Environment
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6.3

Importing a File into a Design

To import a file into a design:
1. Right click in the Design Window
2. Click on Import in the menu to display the Import File dialog box
3. Navigate to locate required file and select it
4. Click on Open to import it
An Icon is added into the currently active folder.
The document Icon graphic indicates which Editor will be used to edit the imported document
e.g. a PCB document will have a PCB icon, indicating that it will be opened by the PCB
editor. A Microsoft Word document will have the familiar Word icon, indicating that
Microsoft Word will open it.
You can import directly from the Windows File Explorer into the Design Explorer by clicking
and dragging the folder or document.
Any folder hierarchy that exists in a dragged folder is automatically recreated in the Design
Explorer.
Note! When using a database, the original file is not removed from your hard disk.

6.4

Editing Non-Protel Documents

Protel’s Smart Technology allows you to add non-Protel documents to a Design. Document
created by ActiveDoc compliant editors (such as Word and Excel documents) can be edited
from the Design Explorer. E.g. when you double-click on the Word document icon, Word is
launched.

6.5

Linking to an External Document

Linking allows you to associate a document to a project without having to store it in the
Design Database.
Linked documents are stored in the Design Window in the normal way.
However (because the document is external) moving, deleting and backing up etc must be
done separately.
Caution! You cannot lock an external document while you are working on it. This could
result in two designers having the same linked document open and overwriting each other.
To link a document:
•

Right click in the Design Window

•

Click on Link

•

Navigate to the required document in the dialog box that appears

•

Select the document then click on Open to link it

An icon is added to the current folder.
20
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Notice! The icon has a small arrow in the bottom left corner to indicate that it is a linked
external document.

6.6

Exporting Documents from the Design

You can export a document from a design to the Windows file system. This applies for both
Design Storage methods.
To export a document:
1. Right click on the document icon in the Design Window
Notice that a floating menu is now displayed
2. Select export
Notice that the export dialog box is displayed
3. Navigate to the location where you wish to save the document then click Save
Note 1 The icon is not deleted from the design database!
Note 2 You can export an entire folder (with sub-folders). A folder of the same name is
created on the hard disk and all documents and sub-folders in the selected Design are
exported.

6.7

Working with Existing Protel Designs

If you open an existing Schematic or PCB document (e.g. one created in Protel 98), it will
automatically be imported into a new design and then opened for editing.
Steps:
1. Select File » Open menu command
2. Set the File Type to All Files
3. Select the existing Protel document
4. Click on Open
At this point you will be prompted to save the document as a Design Database.
5. Enter the Database file name and click on OK
Note! The document that is imported into the Design Database is a copy of the original file. If
you edit the document and wish to update the original copy, you must export the edited
document out of the Database.

Design Explorer Environment
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7 Design Team Concepts
Design Explorer provides the ability to control access to folders and documents within a
database. This is implemented in a similar manner to network access control. Each database
has provision for a Design Team to be set up. Each user requiring access to the database has to
be added as a member of the design team. Permissions can be assigned to documents or
folders to allow or limit the access to Design Team members.
Once you protect a Design Database with a password, subsequent users are required to enter a
login name and password when they wish to access the design. Password protecting a new
Design Database automatically assigns an Administrator to oversee it. The Administrator
thereafter determines and controls membership and access levels.
Establishing Administrator:
1. Select File » New Design
2. Click on Location Tab and enter name for database
3. Relocate design database if necessary
4. Click on Password Tab
5. Click on Yes to password protect the new design
6. Enter a password
Note! The password that is entered is automatically allocated to the Administrator.
Henceforth, when the administrator wishes to access the Design Database he will log in as
ADMIN and key in the password. Once the Administrator has access to the database he/she
can allocate memberships and access levels.
Creating New Members:
1. Log into the database as the Administrator
2. Single click on the Design Team icon in the navigation panel.
3. Single click on the membership icon in the Navigation Pane or double-click on the
membership icon in the Design Window.
4. Right click on an empty space in the Design Window.
5. Select New Member from the floating menu that appears.
A new member will be created and the
User Properties dialog box will open.
6. Enter the new member’s name. This
is the name that the new member
will use to log in.
7. Enter information in Description
field (this is optional).
Password field is optional but if entered
must be entered when logging in. The
password is case sensitive.
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7.1

Determining Levels of Access

Permissions determine the access levels team members have to folders and documents in a
design. There are four types of Permissions.
Permission Level

Permissions Allowed

Read (R)

Permitted to open folders and documents

Write (W)

Permitted to modify and save documents

Delete (D)

Permitted to delete documents and folders

Create (C)

Permitted to create documents and folders

Table 1 Access Level Permissions

The default behaviour of Permissions in the Design Database system is to allow members
freedom to Read, Write, Create and Delete. The Administrator can subsequently restrict or
expand the access levels for any or all members.
Permissions work in a hierarchical manner. Member access can vary from level to level in the
Design Database.
Importantly Permissions defined at a lower level in the design database override more general
Permissions allocated at higher levels in the database. This structure permits an Administrator
to restrict or expand access across the design.
The example below should help to clarify how the Permissions structure works.

In the Permissions folder above the Administrator has total freedom throughout the database
ie. the administrator can Read (R), Write (W), Delete (D), and Create (C)
Notice that team member; Max Harris is entered four times in the Permissions folder.
At the highest level of the Permissions hierarchy, Max has total freedom. If this were the only
permission entered for Max Harris, he would have total freedom throughout the design
database. However, the Administrator has decided to restrict Max Harris’ access in some areas
of the design. He enters three more Permissions at lower levels limiting Max’s access.
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Study the Permission entries for Max Harris that follows to reinforce your understanding of
the ‘hierarchical’ nature of Permissions.
At the highest folder in the Design Database Max is given total freedom.

At the Design Team level Max is permitted to Read, Write and Create but he does not have the
ability to Delete.

Max is prohibited from having any access at the Permissions folder level.

At the Sessions Folder level Max has permission to Read but cannot Write, Create or Delete.

This hierarchical relationship means an administrator can “cordon off” sections of a design
database. He can restrict access in a specified lower level and allow total freedom in the rest of
the database. Conversely, he can allow total freedom in a specific lower level and restrict
access in the rest of the database.
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7.2

Restricting and/or Expanding Access Levels

Steps:
1. Log into a design database as the Administrator
2. Click on the Design Team icon in the Navigation Pane
3. Click on Permissions Tab in the Navigation Pane
4. Double-click on a member to bring up the Permission Rules Properties dialog box.

5. Edit the Document Scope field if required i.e. stipulate the folders that you wish the
Permission to control.
6. Mark the desired check boxes and click on OK. E.g. in the dialog box above Max has
permission to read, write and create in the Design folder.

7.3

Multiple Access Levels for the Same Member
The Administrator may decide that the
access for a particular member should
vary within the database i.e. the member
may have complete access to some parts
of the design but more limited access to
other parts.
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Steps:
1. Click on Permissions Tab
2. Right click on empty space in the window and then left-click on the New Rule button that
appears
3. Click on Down Arrow and select the required member from the list
4. Enter information in the Document Scope field, i.e. defines the folders that the permission
will control.
5. Check the desired permission check boxes and click on OK

7.4

Monitoring Opened Documents

It can be important to know which documents a team member has open when you are working
on a database as a team.
The session’s folder lists the name and location of currently opened documents. It also
indicates the team member that has it open, the name of the computer it is opened in and its
Locked or Unlocked status (see next section)

7.5

Locking a Document

Team Members have the option of Locking the document or documents they are working on.
Once a document has been locked, it can only be un-locked by the team member that locked it.
Other team members with the appropriate Permissions can open locked documents but they
cannot edit them. When the team member that locked the document closes it, the document is
automatically unlocked.
Steps:
1. Right click on a document icon in the sessions folder
Notice that the Lock/Un-lock button appears.
2. Left click on the button to activate the command

7.6

Libraries

Libraries are stored within a database just like all other design documents. The library
databases are stored in the Design Explorer 99 SE \Library folder.
If you have existing libraries that you need to keep as .LIB format files, you can still work with
these. The easiest way to use libraries in both Protel 98 and Design Explorer is to create new
library databases and then link (rather than import) the existing company libraries to them.
Exercise
1. Locate and open the Z80 Microprocessor Database Folder - it is located in the Examples
folder of Design Explorer directory.
2. Expand and then contract the contents of the database.
3. Single click on a folder in the Explorer to display its contents in the Design Window.
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4. Single click on a document in the Explorer to display it in the Design Window.
5. Single click on a few more folders and documents in the Explorer to activate them.
6. Click and drag to move folder to another location in the Explorer.
7. Right click on one of the Folder tabs at the top of the Design Window and select Tile All.
8. Right click on one of the tabs in the multiple screens and select Merge All.
9. Create a new folder in the Database by right clicking on an empty space in the Design
Window.
10. Right Click on a folder in the Design Window and copy it to the new folder you created.
11. Double-click on an folder icon in the Design Window to display its contents
12. Double-click on a document icon in the Design Window to open it
13. Use the click and drag method to select all the documents and folders displayed in the
Design Window.
14. Create a new database and protect it with a password.
15. Establish an Administrator for your database
16. Create two new members for your database
17. Give different access levels to the two members
18. Create a Library folder in your new database
19. Import a library into your new database
Steps:
•
•
•
•
•
•

Create a library folder
Make the library folder active
Select File » Import
Navigate to Design Explorer 99 SE\Library\Sch
Select one of the Library databases
Select Open

20. Rename a document or folder in the Database you created
21. Import an external document into your database using drag and drop
22. Link an external document to your database
23. Import a document from the Z80 Microprocessor database into your database
24. Export a folder from your database to the Microprocessor database.
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8 Customisation of Toolbars, Menus and Shortcut Keys
General Points:
•

All methods of command selection can be customised.

•

This includes Menu, Toolbars and Shortcut Key menus

•

All commands in all editors are accessible for customisation.

•

Menus, Toolbars and Shortcut Key menus are often referred to as Resources in Design
Explorer documentation.

•

Popup menus and Right Mouse Click menus are part of the Menu.

Figure 16 Toolbar Properties Dialog Box

8.1

Selecting a Resource Editor

Activating the appropriate resource editor dialog box customises resources.
Double-click on an empty space on a toolbar or a menu you wish to customise to activate the
appropriate resource editor. (Alternatively click on the System menu, select the Customise
option and then select the toolbar or menu you wish to customise)
All the resource editors function in a similar manner. Figure 16 above shows the Toolbar
Properties dialog box.
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8.2

Processes and Parameters

Commands behind Menus, Toolbars or Shortcut Keys (resources) are referred to as Processes.
When adding a command to a resource, you need to select a process to associate with that
resource. Each of the resource editor dialog boxes provides you with a browse button to search
the list of processes available with each Server.
Documentation on the available process for an editor can be found in the On-line Help. Also,
once you have selected a process in any of the resource editor dialog boxes, pressing the Info
button will display help for that process.
Adding parameters can further customise the operation of any process.
A very good example of the use of parameters is the Digital Objects toolbar in the Schematic
Editor. To display this, select View » Toolbars » Digital Objects.
Exercise - Adding a Command to a Toolbar
1. In this exercise we will add the View » Area command to the Main toolbar of the Schematic
editor.
2. While in a Schematic document, double-click on the Main Toolbar (position the cursor to
the right hand side of the far right button). If the cursor is correctly positioned, a tool tip
will display, saying click and drag to reposition or double-click to edit.
3. This will display the Toolbar Properties dialog box.
4. The scroll box displays all the buttons currently assigned to the toolbar.
5. Scroll down until the Display command toolbar buttons are visible
6. Click on the space immediately after the Zoom Document button and then press the right
mouse button and choose add. This will add a new unassigned button to the toolbar.
7. Double-click on the new button. This displays the Button Toolbar dialog box.
To assign a command (process) to this toolbar button, click on the Browse button next to the
Process drop down box.

Figure 17 Process
Browser Dialog Box
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8. In this dialog box select Sch in the Show processes for drop down box. This displays all
the processes for the Schematic Editor.
9. Key z into the Filter field so that only processes starting with z are listed. This simplifies
the task of locating the Zoom Window process.
10. Click on Sch:ZoomWindow and then click on OK.
11. Click on the Browse button next to the Bitmap File field and find the bitmap called
ZoomWind.bmp. Double click to assign it the our toolbar button
12. If you would like to put you own tool tip to go with your new toolbar button, add the
following text to the Parameters field of the dialog box: $Description=my own toolbar
button
13. Once you are happy with the graphic on the button, close out of the dialog box and make
sure that the button has been added to the Main toolbar.
14. Test the button.
15. Read your tool tip.
Exercise- Adding an Item to the Main Menu
In this exercise you will add an extra wiring toolbar option to the View menu.
1. While in a Schematic document, position the cursor to the right of the Help in the menu bar
and double-click: the Menu Properties Dialog box will appear.
2. Double-click on View to display the View menu commands.
3. Move your cursor down the first category of commands (i.e. Fit Document etc.) until the
cursor rests on the first separator line (a line with no command associated with it).
4. Click on the separator line.
5. Right Click and choose Separator to add a new separator
6. Click on the new Separator line (the one below the highlighted one)
7. Right Click and choose Add
8. Notice that the words Menu Item appear.
9. Type My Wiring Tools in the Menu text box in the lower section of the Menu properties
dialog box
10. Click on the Browse button next to the process drop down box. The Process Browser
Dialog box appears.
11. Choose Client in the Show processes for drop down box.
12. Scroll through Dialog box and select the Client: Customise Resources process
13. Right click and choose Test Menu
14. Click on View in the Menu that appears
15. Notice that My Wiring Tools appears as an option on the View menu.
16. Exit from the test menu display
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17. Click on the Close button to return to the document editor.
18. If you now click on View, you will notice that My Wiring Tools appears as an option.
19. Clicking on this option will toggle the Wiring Toolbar on or off
Exercise: Adding an Item to the Right Mouse Click Menu
In this exercise we will add the View » Area command to the Right Click menu of the
Schematic editor.
1. While in a Schematic document, position the cursor to the right of the Help in the menu bar
and double-click to display the Menu Properties dialog box.
2. Double-click on Help to expand its contents.
3. Scroll through to locate the entry Right Mouse Click {Right_Click}
4. Click on the first item under Right Mouse Click
5. Right click and then choose Separator
6. Right click again and choose Add
7. Notice that the words Menu Item appear
8. Right click and choose Separator
9. Add the Zoom area command to the menu in the same manner as the previous exercise
Once the command is added, Right Click to test the command.

Figure 18 Menu Properties
Dialog Box
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8.3

Creating a New Menu, Toolbar or Shortcut Key Menu

Creating a new Menu, Toolbar or Shortcut Key menu is similar to editing one. The procedure
is outlined below.
Create the Resource
Select the Customise command from the System menu (the down arrow to the left of the File
menu). This displays Customise Resources dialog box shown in Figure 19.

Figure 19 Customize Resources Dialog Box

From this dialog box you can:
•

Create a new resource

•

Delete a resource

•

Edit a resource

•

Copy a resource from an existing one

To create a new resource, you click on the tab for the resource you want to create. You then
Right click and choose New. You then add processes as if you were editing an existing
resource. When a new resource is created, it is automatically associated with the current editor.
The procedure to make each type of resource active is described below:
Menu: Only one menu can be active at any one time but any number of menus can be
associated with an editor. To make a new menu active, select it from the Current Menu drop
down box in the Menu tab of the Customise Resources dialog box. If you create a new menu it
will automatically be the current menu.
Toolbars: Any number of toolbars can be active. When a new Toolbar is created, it is
automatically active. To turn off a tool bar, you locate its check box in the Available Toolbars
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scroll box in the Toolbars tab of the Customise Resources dialog box. Checked toolbars are
active.
Shortcut Keys: Only one Shortcut Key table can be active at any one time but any number of
them can be associated with an editor. To make a new Shortcut Key table active, select it from
the Current Shortcut Table drop down box in the Menu tab of the Customise Resources dialog
box.

9 Text Editor
The Text Editor is a general-purpose text editor that you can use to view or edit text
documents. There are a number of commands in the various document editors that generate
text documents. These automatically open the Text Editor and display the text document that
was generated. For example, the Reports » Bill of Material menu command at your disposal
while in a Schematic document generates a parts list of your schematic and then switches to
the Text Editor and displays the parts list.

Figure 20 Text Editor

The Text Editor Panel provides a number of facilities to aid in searching for text. These are
described in section 1.6.1.
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9.1

Searching

The Find section of the Text Editor Panel enables you to find occurrences of specific text
within files open in the Text Editor. To find a string of text, you click on the top field in the
Find section and key in the text string you want to search for and then press the Search button.
If any occurrences of the text string are located, their line numbers are listed in the lower of
the two large fields in the Find section. The string that was searched for is displayed in the
upper of the two large fields in the Find section.
To select the line of the text file containing the string, click on that line number. To return to
that line after doing other commands, press the Goto button. If you initiate search for another
string, the Text Editor will keep the results of the current search unless you press the Clear
button.
Each new search will add a line to the upper field. Double-clicking on a line in the upper large
field will display the occurrences of that string in the lower large field.
The check boxes in the lower part of the Find section perform the following:
Find Options

Function

Case Sensitive

Search will ignore the case of characters if unchecked

Whole Word

If checked, search will locate strings with spaces either side

All Text Docs

If checked, all text documents open in the text editor will be searched

Table 2 Text Editor Find Options

9.2

Location Markers

Location Markers enable you to mark a cursor location in the text file. You can then return to
that location as required. There are ten location markers in the Text Editor. The Location
Marker controls are located in the Location Marker section of the Text Editor Panel.
To set a location mark, position the cursor at the desired location and check the check box for
one of the Location Markers. Now, each time you press the button next to that Location
Marker check box, the cursor will return that that Location Marker position.

9.3

Syntax Highlighting

The Text Editor has a feature known as Syntax Highlighting, which is very useful when
working with structured documents such as source files for programming languages. The
Syntax Highlighting displays key words in the file in pre-defined colours.
Syntax Highlighting is determined by the file extension. For example files with the extension
.bas will use the Syntax Highlighting defined for Basic.
You can define you own Syntax Highlighting and modify existing definitions using the Tools
command.

» Change Language menu
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10 Schematic Editor Basics
The Schematic Editor makes use of all the workspace features in the Design Explorer
environment. This includes multiple toolbars, Resource editing, Right Click menu, Shortcut
Key table, Tooltips and Autosave.

Figure 21 Schematic Editor Workspace

In this section we will explore the basics of working in the Schematic Editor.
If it is not already open, open the schematic sheet, CPU Section.sch in the Z80
Microprocessor.ddb database (as shown in Figure 21).
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10.1 View Commands
The View commands can be accessed in the View menu. The table below lists the main display
commands:
Command

Toolbar
Icon

Shortcut
Key

Description

Fit Document

VD

Display entire document

Fit All Objects

VF

Fits all objects in the current document
window

Area

VA

Display a rectangular area of document by
selecting diagonal vertices of the rectangle

Around Point

VP

Display a rectangular area of document by
selecting the centre and one vertex of the
rectangle

50%

V5

Set display magnification to 50%

100%

V1

Set display magnification to 100%

200%

V2

Set display magnification to 200%

400%

V4

Set display magnification to 400%

Zoom In

VI

Zoom In around current cursor position

Zoom Out

VO

Zoom Out around current cursor position

Pan

VN

Re-centre the screen around the current
cursor position

Redraw

VR

Update the screen display

Table 3 View Command Summary

While executing commands, Auto-Panning becomes active (when the “cross-hair” is attached
to the cursor) by touching any edge of the design window.
Auto-Panning speed is controlled via Auto Pan Options section of the Graphical Editing tab
within the Preferences dialog box (Tools » Preferences). Auto panning can also be turned off
here.
While Auto-Panning, pressing the Shift key will double the panning speed.
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The following shortcut keys provide a very useful alternative for manipulating the view of the
workspace. Note that these can be used while executing commands.
Keystroke

Function

END

Redraws the view

PAGE DOWN

Zoom out (holds the current cursor position)

PAGE UP

Zoom in (holds the current cursor position)

CTRL PAGE DOWN View Document
HOME

View pan (pan to centre the current cursor position)

SPACEBAR

Stops screen redraw

ARROW KEYS

Moves the cursor by one snap grid point in the direction of the
arrow

SHIFT + Arrow Key

Moves the cursor by 10 snap grid points in the direction of the
arrow

Table 4 Shortcut Keys For View Manipulation

10.2 Location Markers
These allow you to store up to 10 locations in you schematic document. You can then return to
these locations using the Jump command.
To set a location marker, select Edit » Set Location Marks and select from location marks 1 to
10. You then use the cursor to position the location mark.
To return to that location, select Edit » Jump » Location mark x (Jx) and the display will be
centred on that location mark.

10.3 Selection
The Schematic Editor provides Selection capabilities that are similar although not identical to
Selection in other Windows applications.
Below are some key points about Selection in the Schematic editor:
•

The main use of Selection is to nominate objects for a clipboard operation i.e. to nominate
which objects will be moved or copied to the clipboard when the Cut or Copy commands
are invoked.

•

Once objects are on the Clipboard, they can then be pasted elsewhere onto the current
schematic or into another schematic or to another Windows application which supports the
Windows Clipboard

•

Selection is cumulative. Objects that have been selected remain selected until they are deselected.

•

Ctrl+Del deletes all selected objects
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To select an object you can use:
Keystroke

Function

Click+Drag

Select all objects enclosed by drag area

SHIFT+Left Click on object

Select an object (on a selected object this will de-select it)

Edit » Select.... menu (S)

Select Inside Area, Outside Area, All, Net or Connection

Select Inside Area

Button on main toolbar

Table 5 Select Command Summary

Selected objects can be:
Keystroke

Function

Cut, Copied, Pasted or cleared

Using the Edit menu commands

Moved

Click and hold on any selected object

Moved or Dragged

Using the Edit » Move menu commands (M. Shortcut keys)

Aligned

Using the Edit » Align menu commands (A. Shortcut keys)

Deleted

Using CTRL+DELETE

Table 6 Selected Object Command Summary

To DE-SELECT objects, use the Edit » DeSelect menu commands (X
for popup menu) or the DeSelect All button on the Main toolbar.
Hints on Selection
•

Before starting a selection it is a good idea to de-select all objects first.

•

Only items that fall completely inside the selection area are selected.

•

The selection colour is set in Options » Preferences dialog box.

•

The Move menu allows you to move selections:
- Without maintaining connectivity (move)
- Maintaining connectivity (drag)

•

The S key pops up the Select menu

•

The X key pops up the De-select menu

10.4 Focus
Focus is provided to allow you to graphically edit single objects.
Below are some key points about Focus:
•
38

An object is put into focus by clicking on it.
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•

When in focus, handles appear at key points on the object, or if it is a component or text, a
dashed line appears around it.

•

Clicking on another object will make it the current focus.

•

The method for editing objects in focus varies between objects, but typically an
instantaneous click on a handle enables you to move the handle.

•

An instantaneous click on a segment of an object in focus allows you to move it.

•

Only one object can be in focus at a time. When you single click to focus on another
object, the previous object will no longer be in focus.

Note: You can edit a text object by first putting into focus and then clicking on it again. You
can then move the cursor using the arrow keys to the characters requiring editing.
To De-Focus an object, simply click in an area of the workspace where there are no objects.
When an object is in focus the following key strokes / mouse actions will:
Keystroke

Function

DEL

Delete the item

Click on Handle

Move a handle

Click on Segment

Move a segment

INSERT+Click

Insert a new handle

Click & hold on
Handle+DEL

Delete a handle

Table 7 Focused Object Command Summary

10.5 Other mouse actions:
The mouse operations listed below are universal throughout the Schematic editor and should
be used in preference to menu commands:
Keystroke

Function

Click-and-hold on object

Move an object

CTRL+Click on object

Drag an object whilst maintaining connectivity, space
bar to change mode

Double Click on object

Edit an object’s properties

Click Left button

ENTER

Click Right button

ESCAPE

Table 8 General Mouse Shortcut Summary

While an object is on the cursor, the following applies:
•

Spacebar to rotate
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•

X key to flip around the vertical axis

•

Y key to flip around the horizontal axis

•

Hold the Alt key to allow only vertical movement

•

Hold the Alt key and the Shift key to allow only horizontal movement

10.6 Multiple Objects at the Same Location
When working in the Schematic editor, the situation sometimes occurs where a click to
perform an operation is made where there are multiple objects. In this situation, the editor
pops up a menu listing all the objects it has detected at the location of the click. You can then
select off this menu the object you wish to operate on.

Figure 22 Menu listing objects at mouse click point

10.7 Exercise – Schematic Editor Basics
Zooming and Panning
16. Open the schematic document CPU Clock.sch in the Z80 Microprocessor.ddb database.
17. Experiment with each of the display commands listed in Table 3 using the View menu,
Shortcut keys and the Main toolbar:
18. Select the menu command Place » Annotation (PT) and experiment with the Shortcut keys
listed in Table 4 in conjunction with the display commands you have just mastered. To exit
the command, hit the ESCAPE key or click the right mouse button.
19. Now try Auto-Panning. Select the menu command Place » Annotation (PT) again, then
move the cursor to an edge of the window. The display will start panning. Select the
SHIFT key while the display is panning. Note the “cross-hair” cursor displaying while the
Place » Annotation command is active.
Location Markers
1. Set Location Mark 2 by selecting Edit » Set Location Marks » Location Mark 2 (L2) and
then click in the schematic sheet the position for the location mark.
2. Zoom out to another part of the schematic.
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3. Select Edit » Jump » Location Mark 2 (J2) and the screen will centre on location mark
number 2.
Focus, Selection and Mouse Actions
1. Click on the crystal. Observe the dashed box indicating the crystal as the focused object.
2. Click on the crystal a second time. The part will now be 'lifted' off the sheet and can be
moved. It is re-placed by clicking on the left mouse button.
3. Click on the capacitor. It will now be the focused object.
4. Click somewhere on the sheet where there are no parts. Nothing will be in focus now.
5. In a clear area of the sheet, draw a line with a few vertices using Place » Drawing Tools »
Line or Place Line from the Drawing Tools toolbar.
6. Click on the line to bring it into focus. Notice the handles are now displayed.
7. Experiment with moving a vertex, moving a segment (a length of line between two
vertices), adding a vertex (INSERT then left click) and deleting a vertex (left click then
DELETE).
8. DeSelect all objects on the sheet using Edit » DeSelect »
All (Shortcut keys XA) or on the main toolbar.
9. Using the click and drag selection feature, select the three inverters, the resistors, capacitor
and crystal. The selected objects will be highlighted with a yellow box.
10. Using the Edit » Copy menu command, copy the items to the clipboard.
11. Open a new sheet and paste the clipboard contents onto it. DeSelect the pasted objects.
12. Close the new sheet (no need to save it).
13. Try moving the selected objects on the original sheet using the Edit » Move menu
commands.
14. While holding the CTRL key, click on the capacitor. You can now drag the capacitor whilst
maintaining connectivity.
15. Double-click on one of the 74LS04s. The Edit Part dialog box will pop up. You can now
edit any of the device’s properties. Click on the hidden pins check box. Click on the OK
button. Notice the two extra pins that have appeared on the device. These are the power
pins, more on these later. Re-hide the power pins.
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11 Schematic Graphical Objects
In General:
•

Use the Drawing Tools toolbar to place the graphical objects.

•

When an object is in focus its handles are displayed.

•

When placing an item press the TAB key to edit its properties.

•

Turn the Drawing Tools toolbar on and off using this toolbar
button in the main toolbar, or the View » Toolbars » Drawing
Tools menu command. All drawing toolbar functions can be accessed through the Place »
Drawing Tools menu.

Re-entrant Editing
While in a command, you can select another command without quitting the first command
provided you use a shortcut key. This powerful capability will considerably enhance your
productivity. Experiment with it in the exercises.

Figure 23 Graphical Objects
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11.1 Summary of Graphical Objects
For an example of each graphical object open the schematic sheet Graphical Objects.sch in the
Training.ddb database.
11.1.1 Lines

To draw a line;
•
•
•
•
•
•

Select the Place Line toolbar button
Left-Click once to start the line
Left-Click to place each vertex
The Backspace key deletes the last vertex placed
Right-Click once to end the line
Right-Click again to end the command

11.1.2 Polygons

To draw a polygon;
•
•
•
•
•
•

Select the Place Polygon toolbar button
Left-Click to place each vertex
Right-Click to end the polygon
Right-Click again to end the command
The fill colour and border colour are independent.
Turn the Draw Solid option off in the Polygon dialog box to draw a polygon that is not
filled.

11.1.3 Arcs

To place a circular arc;
•
•
•
•
•
•

Select the Place » Drawing Tools » Arcs menu command.
Left-Click to place the arc centre
Left-Click to determine the arc radius
Left-Click to place the start of the arc
Left-Click to place the end of the arc
Right-Click to end the command.

11.1.4 Elliptical Arcs

To place an elliptical arc;
•
•
•
•
•
•
•

Select the Place Elliptical Arc toolbar button
Left-Click to place the arc centre
Left-Click to determine the arc X-radius
Left-Click to determine the arc Y-radius
Left-Click to place the first end of the arc
Left-Click to place the second end of the arc
Right-Click to end the command
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11.1.5 Bezier Curves

A Bezier curve is a curve of best fit between points defined by mouse clicks. To draw a Bezier
curve:
•
•
•
•
•
•
•
•

Select the Place Bezier Curve toolbar button
Left-Click once to place the first control point
at the start of the curve
Left-Click to place the second control point
Left-Click to place the third control point
Left-Click to place the fourth control point
Continue to Left-Click to place further control points
Right-Click to end the command
To reshape the curve, focus it (click on one end of the curve) and then move, insert or
delete new control points (handles).

11.1.6 Annotation (Text)

To place a line of text;
• Select the Place Annotation toolbar
button
• Press TAB to edit the contents and the font of the text
• Left-Click to position the text
• Right-Click to end the command
11.1.7 Multi-Line Text Frames

These are used to place paragraphs of text on the sheet.
•
•
•
•
•
•
•

To place a text frame;
Select the Place Text Frame toolbar button
Press TAB to edit the contents and
properties for the text frame
Select OK
Left-Click to position the top left corner of the frame
Left-Click to position the bottom right corner of the frame
Right-Click to stop placing text frames

The following keys apply when entering text into the frame:
Action

Keystroke

Insert a TAB

Ctrl-TAB

Cut

Shift-Delete or Ctrl-X

Copy

Shift-Ins or Ctrl-C

Paste

Shift-Ins or Ctrl-V

Table 9 Text Frame Action Summary
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The Cut, Copy and Paste apply to the Windows clipboard. The clipboard can also be used to
bring text in from other applications.
Check in Help for information on each field in the Text Frame dialog box.
11.1.8 Rectangles

To place a rectangle;
•
•
•
•

Select the Place Rectangle toolbar button
Click-Left to place top left corner
Click-Left to place bottom right corner
Click-Right to end the command

11.1.9 Rounded Rectangles

Rounded rectangles are rectangles with rounded corners. The radius of the arcs at the rectangle
corners are set in the X-Radius and Y-Radius fields in the Round Rectangle dialog box.
To place a rounded rectangle;
•
•
•
•
•
•

Select the Place Rounded Rectangle toolbar button
Press TAB to set the corner radii
Select OK
Click-Left to place top left corner
Click-Left to place bottom right corner
Click-Right to end the command

11.1.10 Ellipses

Also use this object for circles. To place an ellipse;
•
•
•
•
•

Select the Place Ellipse toolbar button
Left-Click to place the ellipse centre
Left-Click to determine the ellipse X-radius
Left-Click to determine the ellipse Y-radius
Right-Click to end the command

11.1.11 Pie Shapes

To place a pie shape;
• Select the Place Pie Shape toolbar button
• Left-Click to place the pie centre
• Left-Click to determine the pie radius
• Left-Click to place the first edge of the pie
• Left-Click to place the second edge of the pie
• Right-Click to end the command
11.1.12 Graphical Images

Graphical images with the following formats can be added to your schematic:
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1.
2.
3.
4.
5.

.bmp
.rle
.jpg
.tif
.wmf

The file containing the graphical image is not inserted into the sheet. Instead, pointer to the
file is placed in the sheet. For this reason the image file must be transferred with the
schematic file when moving the schematic from one location to another.
To place a graphic image;
•

Select the Place Graphical Image toolbar button

•

Locate the file that contains the image

•

Select OK

•

Left-Click to place the top left corner of the image

•

Left-Click to place the bottom right corner of the image

•

Select cancel to end the command

11.1.13 Paste Array

This command places all objects on the clipboard in an array defined in the dialog box shown
below. Any text object on the clipboard finishing with a number will incremented.
To place an array;
•

Select and copy the required items to the clipboard

•

Select the Array Placement toolbar command

•

Set the placement variables in the Set up Paste Array dialog box. Use Help for explanation
of each variable.

•

Select OK

•

Left-Click to place the array

•

DeSelect All

Figure 24 Set up Paste Array dialog box
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11.2 Font Management
Fonts are controlled via the Font dialog box. This dialog box will pop up whenever you edit
text and click the Font Change button.
Changing the font for text that cannot be edited directly, such as pin names, port names and
sheet text is done via the Change System Font button in the Document Options dialog box
(Design » Options).
The Font dialog box allows you to examine what fonts are available.
Verify that the correct printer is selected in Printer Setup.

Figure 25 Font dialog box

11.3 Exercise – Schematic Graphical Objects
Explore Drawing Tools
•

Create a new sheet (File » New) and experiment with placing each of the graphic objects
you have just been introduced to.

•

Put each object into focus and observe the handles.

•

Investigate the effect of moving handles.

•

Close the sheet and don’t save.
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12 Schematic Electrical Objects
In General
•

Use the Wiring Tools toolbar to place Electrical Objects

•

Electrical objects are those that have some part the play in representing components or
connections.

•

Turn the wiring toolbar on and off
using the button on the main toolbar.

•

All Wiring Tools toolbar functions can be accessed through the Place menu

•

Text in electrical objects can be over scored, typically to indicate an active low signal, by
placing ‘\’ at the start of the text string e.g. \reset would display as over scored text.

In the following paragraphs, the use of each electrical object is explained.

Sheet Symbol
PCB Routing Directive

Sheet Entry
BAUDCLK
BAUDCLK.SCH
BAUDCLK

Part

Ports

U6
Z80ASIO0
20

CPUCLK

7
6
5

VCC

INT

A[0..15]

A[0..15]

A0
A1
RD
IORQ
M1
RESET
SIOSEL

D[0..7]

D[0..7]

D0
D1
D2
D3
D4
D5
D6
D7

Bus

34
33
32
36
8
21
35
40
1
39
2
38
3
37
4

CLK
IEO
IEI
INT
B/A
C/D
RD
IORQ
M1
RESET
CE
D0
D1
D2
D3
D4
D5
D6
D7

DCDB
DTRB
CTSB
RTSB
W/RDYB
SYNCB
TXDB
RXTXCB
RXDB
DCDA
DTRA
CTSA
RTSA
W/RDYA
SYNCA
TXCA
TXDA
RXCA
RXDA

22
25
23
24
30
29
26
27
28

Net Label
W/RDYB

19
16
18
17
10
11
14
15
13
12

Power Port
Junction
Wire

Bus Entry

No ERC

Figure 26 Electrical Objects
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12.1 Summary of Electrical Objects
For an example of each electrical object open the schematic sheet Electrical Objects.sch in the
Training.ddb database.
12.1.1 Wires

•
•
•
•
•
•
•
•
•
•
•
•

Wires are used to represent an electrical connection between points.
Be careful not to use the Line object instead of the Wires object.
Press the Spacebar to change the Placement mode. There are 6 placement modes as
follows:
90 Degree Start
90 Degree End
45 Degree Start
45 Degree End
Any Angle
Auto Wire
The Backspace key deletes the last vertex placed
A wire end must fall on the connection point of an electrical object to be connected to it.
For example the end of a wire must fall on the hot end of a pin to connect.
Wires have the Auto Junction feature, which automatically inserts a Junction object if a
wire starts or ends on another wire or runs across a pin.

12.1.2 Buses

•

•
•

Buses are used to graphically represent how a group of related signals, such as a data bus
are connected on a sheet. They are also used to collect together all the signals belonging to
a bus on a sheet and connecting them to a Port to enter or leave a sheet. In this instance
they must have a net label of this format : D[0..7].
Place a bus line in the same manner as placing wires – press Spacebar to change placement
mode, Backspace key to delete the last vertex placed.
Buses can only represent connections to Ports and Sheet Entries and only at their end
points.

12.1.3 Bus Entries

•
•
•
•
•
•
•
•

Bus entries are used to represent a connection between a wire and a bus.
To place a bus entry;
Ensure that an appropriate snap grid is set so that connections will be made
Select the bus entry toolbar button
Press the space bar to rotate the bus entry
Left-Click once to position the bus entry
Right-Click to stop placing bus entries
Use of Bus Entries is optional – many users prefer to place a 45-degree wire.
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12.1.4 Net Labels

A net label is used to make a net easily identifiable and also provides a method of connecting
pins belonging to the same net without placing a wire.
A connection is made between all wires with
identical net labels on a sheet. In some cases all
wires with identical net labels in a project will be
connected together. (See Hierarchy later)
All net labels on a net must be identical.
The net list generator will convert all net labels to
upper case.
To associate a net label with a wire, place it so that
its reference point (bottom left corner) falls on the
wire.
The electrical grid is active when placing net labels.
To place a net label:
•
•
•
•
•
•
•
•

Ensure that an appropriate snap grid is set so
that connections will be made
Select the Place Net Label toolbar command
Press TAB to edit the net label text
Click on the down arrow in the Net field to display the names of nets already defined on
the sheet.
Press the space bar to rotate the net label
Left-Click once to position the net label
Right-Click to stop placing net labels
If the last character in a net label is a number, it
will increment when subsequent net labels are
placed.

12.1.5 Power Ports

•
•
•
•
•
•
•
50

All power ports of the same name in a project
will be connected.
To connect to a power port make sure that a
wire falls on the end of the power port pin.
The style of the power port only changes its
appearance. It does not affect the connectivity;
this is established through the Net property.
Power ports will connect to hidden pins with
the same name throughout the design,
regardless of the net identifier scope used.
To place a power port;
Select the Power Port toolbar button
TAB to edit the power port properties
Design Explorer Environment

•
•

Left-Click to position the port
Right click to stop placing power ports

12.1.6 Ports

•
•
•
•
•
•
•
•
•
•
•

Ports provide a method of forming
connections from one sheet to another sheet.
Click on the down arrow in the Name field to
list all the Port names defined on the sheet.
The port I/O Type is used by the ERC when
checking for connection errors.
The port style only changes the appearance
of the port.
To place a port;
Select the Port toolbar button
TAB to edit the port properties
Press the Spacebar to rotate and X and Y flip
Left-Click to position one end of the port
Drag the mouse to set the port length, LeftClick to finish the port
Right click to stop placing ports

12.1.7 Parts

•

When placing parts use a snap grid that will cause the pin ends to fall on a grid point (e.g.
10).

•

When the Place » Part (PP) command is selected the Place Part dialog box is displayed.
You can enter the name of the component in the Lib Ref field or you can click on the
Browse button to locate the part by browsing libraries.

•

Parts can also be placed using the library browser on the editor panel.
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12.1.8 Sheet Symbols

Sheet symbols are used when you wish to break the design into a number of sheets.
A sheet symbol must be placed for each schematic document in the project.
The sheet symbol name is a descriptive name for the sheet.
The sheet symbol Filename property must be the document name of the schematic document it
represents. All sheets in a project should be in the same directory. The correct syntax for the
sheet symbol file name is sub_sheet.sch.
When changing the size of the sheet symbol make sure the edges of the sheet symbol fall on
the snap grid (to ensure connection between wires and sheet entries).
To place a sheet symbol;
•
•
•
•
•

Select the Sheet Symbol toolbar button (PS)
Press TAB to edit the sheet symbol name and sheet symbol file name
Left-Click to place the top left corner
Left-Click to place the bottom right corner
Right-Click to stop placing sheet symbols

12.1.9 Sheet Entries

Sheet entries are used in the sheet symbols if you are doing the design in a true hierarchical
structure, with nets interconnecting the sheet symbols.
Each sheet entry needs a matching port on the sub-sheet.
Use the Sheet Symbols / Port Connections as the net identifier scope when creating netlists or
running the electrical rules checker.
To place a sheet entry;
•
•
•
•
•
•
•

Select the Add Net Connections to Sheet Symbol tool (PA)
Select the sheet symbol that the sheet entry is for
Press TAB to edit the sheet entry properties
Click on the down arrow in the name field to list all the Sheet Entry names used on the
current sheet
Position the sheet entry on either the left or right side of the sheet symbol
Left-Click to position the sheet entry
Right-Click to stop placing sheet entries

12.1.10 Junctions

A junction represents a connection between wires, typically at “T” joins. A junction at the
intersection of the wires will cause them to connect.
The Auto-Junction feature is set in the Schematic tab of the Preferences dialog box. This
automatically places junctions when a wire terminates or starts on another wire.
If you place wires across the ends of pins, junctions will automatically be added.
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12.1.11 No-ERC

Place a No-ERC symbol on the pin to indicate to the ERC that no-connection error messages
are to be suppressed for that pin. These can be suppressed for printing.
12.1.12 PCB Routing Directives

Place a PCB routing directive to associate routing information with a particular net. This
information can then be passed forward to Advanced PCB, using the Protel 2 Netlist format.
The following properties can be attached to a net:
1. Track width
2. Via width
3. Routing topology
4. Routing priority
5. Routing layer
To place a routing directive;
•
•
•
•
•

Select the Add Directives to Nets For PCB Routing button
Press tab to edit the routing directives
Position the routing directives symbol so that its hot point (bottom of the stem) touches the
net
Click-Left to place the routing directive
Click-Right to stop placing routing directives

These can be suppressed for printing
12.1.13 Probe and Stimulus Directives

Probe and stimulation directives are used in OrCAD digital simulation. These can be
suppressed for printing.
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13 PCB Editor Basics
The PCB editor shares all the workspace features offered by the Design Explorer environment.
Use of the PCB editor is consistent with the Schematic Editor, with the following additions:
Layer Tabs: These are located along the bottom edge of the PCB editor display window.
They allow you switch the current layer and give a visual indication of which layers are
currently being displayed and which is the current layer.
MiniViewer: This provides the following functions:
•

Browsing library components

•

Magnified viewing if the workspace

•

Shows a view of where in the workspace the display window currently is displaying

•

View manipulation capabilities

Figure 27 PCB Editor Workspace
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13.1 View Commands
The View commands can be accessed in the View menu or the Main toolbar. The table below
lists the main display commands:
Menu Command

Toolbar
Icon

Shortcut Description

Fit Document

VD

Fits all objects in the current document
window

Fit Board

VF

Fits the PCB to the current document window
using the board outline on the keep out layer

Area

VA

Display a rectangular area of document by
selecting diagonal vertices of the rectangle

Around Point

VP

Display a rectangular area of document by
selecting the centre and then a vertex of the
rectangle

View Selected
Objects

VE

Fits selected objects in the current document
window

Zoom In

VI

Zooms In

Zoom Out

VO

Zooms Out

Zoom Last

VL

Returns display to its state before the last
view command

Pan

VN

Pans the cursor position to centre screen

Refresh

VR

Updates the screen

Table 10 View Command Summary
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The following shortcut keys are very useful for manipulating the view of the document
window. Note that these can be used at any time (i.e. even when executing commands).
Keystroke

Function

END

Redraws the view

ALT+END

Redraw Current layer

PAGE DOWN

Zoom out (holds the current cursor position)

PAGE UP

Zoom in (holds the current cursor position)

CTRL PAGE DOWN

View Document

CTRL PAGE UP

Massive Zoom In around the current cursor position

HOME

View pan (pan to centre the current cursor position)

SPACEBAR

Stops screen redraw

Arrow Keys

Moves the cursor by one snap grid point in the direction of the arrow

SHIFT + Arrow Key

Moves the cursor by 10 snap grid points in the direction of the arrow

Table 11 Shortcut Keys For View Manipulation

Auto-Panning
Auto Panning becomes active when executing commands, (when the “cross-hair” is attached
to the cursor). When in this state, touching any edge of the document window will initiate
Auto-Panning.
Auto-Panning speed is controlled via Auto Pan Options section of the Graphical Editing tab
within the Preferences dialog box (Tools » Preferences). Auto panning can also be turned off
here.
Right Mouse Panning
You can also use the Right Mouse Scroll feature to pan across your PCB document.
•

Place the cursor in the PCB editor workspace

•

Right-click and hold (a hand symbol displays on the cursor)

•

Move the cursor in the desired direction to pan

Note! Once the cursor is off the sheet, the panning will stop and you will need to release the
right button and repeat the process.
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13.2 Location Marks
These allow you to store up to 10 locations in you PCB document. You can then return to
these locations using the Jump command.
To set a location marker, select Edit » Jump » Set Location Marks and select from location
marks 1 to 10. You then use the cursor to position the location mark.
To return to that location, select Edit » Jump » Location mark (JM) and the display will be
centred on that location mark.

13.3 Exercise - PCB Editor View Commands
1. Work through Table 10 to get familiar with each command listed. Use them both from the
toolbar and using shortcut keys.
2. Work through Table 11 to get familiar with each command listed
3. Add the Fit Board command to the Main toolbar with the other view commands
4. (Hint! Use the PCB:Zoom process with the parameter Action=board and use the bitmap
pcb.bmp)

13.4 Focus
Use Focus to graphically edit an object.
Below are some key points about Focus:
•

An object becomes the current focus when you click on it with the left mouse button.

•

When in focus, handles appear at key points on the object.

•

Clicking on another object will make it the current focus.

•

The method for editing objects in focus varies between objects, but typically an
instantaneous click on a handle enables you to move the handle.

•

An instantaneous click on an object in focus allows you to move it.

•

Only one object can be in focus at a time. When you single click to focus on another
object, the previously focused object will no longer be in focus.

•

When placing objects, the last object placed remains in focus.

•

Objects that display a cross and circle when in focus (i.e. fills and text) can be rotated by
instantaneously clicking on the circle.

•

Use focus to edit text objects.

To DE-FOCUS an object, simply click in an area of the workspace where there are no objects.
Note: PCB Components cannot be put into Focus.
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13.5 Selection
The PCB Editor provides Selection capabilities that are similar although not identical to
Selection in other Windows applications.
Below are some key points about Selection in the PCB editor:
•

Selected objects can be cut or copied to the clipboard. They can then be pasted elsewhere
onto the current PCB file or into another PCB file.

•

Selection is normally cumulative. Objects that have been selected remain selected until
they are de-selected. (This can be turned off - see Extend Selection in the Options tab of
the Preferences dialog box).

•

There are a number of PCB editor commands that operate on the selected group of objects
e.g. Tools » Teardrops » Add and the Tools » Interactive Placement commands

•

If you Paste components back into the same PCB document, their Designator text has
“Copy_*” added to it to avoid duplicate designators.

•

The PCB Editor uses a special proprietary clipboard that supports PCB data such as
connectivity and layer properties of primitives. This clipboard is not the Windows
clipboard.

•

To copy a PCB document to the Windows Clipboard, there is a Copy (to Clipboard)
command in the Print/Preview utility (See Printing section).

To select objects you can use:
Keystroke

Function

Click+Drag box around

Select all objects enclosed by drag area

Shift+Left Click

Select an object (on a selected object this will de-select it)

Edit » Select

menu (S)

Select Inside Area
Browse section of the
editor

Select Inside Area, Outside Area or All
This

The following browsers have a Select button to Select the
highlighted objects:
•
•
•
•

Design Rules dialog box

button on main toolbar

Nets
Components
Net Classes
Component Classes

Click on the Select Affected Objects button to select object to
which the current design rules apply

Table 12 Select Command Summary
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Selected objects can be:
Keystroke

Function

Cut, Copied, Pasted or cleared

Using the Edit menu commands

Moved

Using the Edit » Move » Move Selection command

Rotated

Using the Edit » Move » Rotate Selection command

Flipped

Using the Edit » Move » Flip Selection command

Aligned

Using the Tools » Interactive Placement » Align
commands

Deleted

Using Ctrl+Delete key or the Edit » Clear menu command

Table 13 Selected Object Command Summary

Alternatively, you can move the selected group by Clicking and holding on it. While you are
moving the selected group you can:
•

Flip it by pressing the X or Y key

•

Rotate it by pressing the Space Bar

To DE-SELECT objects, use the Edit » DeSelect menu (X)
commands or the DeSelect All button on the Main toolbar.
Hints on Selection
•

Before starting a selection it is a good idea to de-select all objects first.

•

Only items that fall completely inside the selection area will be selected.

•

The selection colour is set in the Colours tab of the Preferences dialog box (Tools »
Preferences).

•

Use Shift+Left Click to select and de-select individual objects.

•

Pressing the S key pops up the Select menu.

•

Pressing the X key pops up the DeSelect menu.

13.5.1 Paste Special

The Paste Special command allows you to control what happens to the properties of the
objects that are on the clipboard when they are pasted back into the workspace.
To execute this command, select Edit » Paste Special. This displays the Paste Special dialog
box shown in Figure 28 where you have the following options:
Paste on current layer
If this option is disabled all single layer objects such as tracks, fills, arcs and single layer pads
keep their existing layer assignments. If this option is enabled then all single layer objects are
pasted onto the current layer.
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Keep net name
If this option is enabled then all objects that have a net name will keep the assigned net name.
If this option is disabled the net attribute is set to “No Net”.

Figure 28 Paste Special Dialog box

Duplicate designator
When pasting components, their Designator text has “Copy_*” added to them if there is a
component with the same designator already in the document. This option turns this off and is
provided to allow panelisation. Typically the Keep net name option is disabled if this option is
enabled.
Add to component class
Pasted component(s) are added to the same class as the component(s) they were copied from
(See the Design Rules section).
13.5.2 Query Manager

This allows you to define selection operations and then repeatedly use them. It also includes a
Wizard to simply setting up selection queries.

13.6 Other Mouse Operations
The mouse operations listed below are universal throughout the PCB editor and should be
used in preference to menu commands:
Keystroke

Function

Click-and-hold

Move an object (While moving the object, press the Space
Bar to rotate it and X or Y to flip it)

Double-Click

Change an object

Click Left button

ENTER

Click Right button

ESCAPE

Table 14 General Mouse Shortcut Summary
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13.7 Multiple Objects at the Same Location
When working in the PCB editor, the situation often occurs where a click to perform an
operation is made where there are multiple objects. In this situation, the PCB editor pops up a
menu listing all the objects it has detected at the location of the click. You can then select off
this menu the object you wish to operate on.

Figure 29 Menu listing objects at mouse click point

13.8 Jump Menu
The Jump menu commands provide you with a number of commands for locating the cursor.
These are described as follows:

Figure 30 Jump Menu Commands

Absolute Origin

Positions the cursor at the Absolute Origin. Ctrl +Home also does this.

Current Origin

Positions the cursor at the Origin. Ctrl +End also does this.

New Location

Positions the cursor at a specified coordinate.

Component

Positions the cursor over the specified component.

Net

Positions the cursor over a pad assign to the specified net

Pad

Positions the cursor over the specified Pad.

String

Positions the cursor over the specified text string in the PCB file.

Error Marker

Positions the cursor over the next DRC error marker.

Selection

Zooms in on the selected group
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13.9 Exercise – PCB Basics
1. Open the document Z80 Processor Board.pcb
2. Turn off Visible Grid 2, set Visible Grid 1 to 0.05” and set the Snap Grid to 0.025”.
3. Place a Fill using the Place » Fill menu command. Observe that when you exit this
command the fill is in focus. Move the handles by instantaneously clicking on them. Move
the fill by instantaneously clicking on the object. Rotate the fill by instantaneously clicking
on the circle within the fill. De-focus the object by clicking at a point away from any
object.
4. Perform the View » Fit Document command on your PCB file.
5. Move a component by clicking and holding on it.
6. While you are moving the component, press the Spacebar to rotate it (Shift + Spacebar for
clockwise rotation) and press the X and Y keys to flip the component in the x and y axes.
7. Select a group of components (Click and hold and then drag the cursor over the
components).
8. Select the Edit » Copy menu command to copy the selected group to the Clipboard (don’t
forget the give the reference location).
9. Select the Edit » Paste menu command. The contents of the Clipboard will now be moving
with the cursor. Rotate and Flip the group as you did when moving a component. Place the
group of components by clicking at the required location.
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14 PCB Design Objects
14.1 General Notes
The object placement commands are selected using either the Place menu or the Placement
Tools toolbar.
To set the properties of an object while placing it, press the TAB key and the properties dialog
box for that object will be displayed.
Once an object is placed, you can change its properties by double-clicking on it to display the
properties dialog box for that object. Alternatively, you can right click on the object and
choose Properties from the menu.
Set the default properties for each object type in the Default Primitives tab of the Preferences
dialog box (Tools » Preferences).
The current layer determines the layer the object is placed on.

Figure 31 PCB Editor Primitive Objects
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14.2 Summary of PCB Design Objects
For an example of each PCB Design object open the PCB document PCB Objects.pcb in the
Training.ddb database.
14.2.1 Tracks

The Interactive Routing command in the Place menu (PT) is used to place tracks with net
information associated with them. The Place » Line command is provided for placing lines
other than tracks such the board outline or as part of as assembly detail. Design rules do not
apply to the Place » Line command.
The Interactive Routing command can be accessed
from the Place menu or this toolbar button.
The place line command can be accessed from the
Place » Line menu or this toolbar button.
There are six track placement modes:
1. Any Angle
2. Arcs on corners
3. 45 degree
4. 45 degree arc with 50mil radius on corners
5. Orthogonal
6. 90 degree arc with 50mil radius on corners
Each mode defines how a track is placed between two vertex points.
Simultaneously press the SHIFT key and the SPACEBAR (once you are in the interactive
routing command) to select a placement mode.
For Option 2, you set the arc radius by holding the , (Comma) to make it smaller and . (Full
Stop) to make it bigger.
In addition, the placement modes are supplemented with a Start Mode and a Finish Mode
(see Figure 31).
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Figure 32 Track Placement Modes

After you have selected the placement mode, you can press the SPACEBAR to toggle between
the Start Mode option and the Finish Mode option.
If a track starts at an object with a net assigned to it, the track will also be assigned the net.
The interactive routing command will adhere to any rules assigned to that net.
Using Focus to Edit Tracks
When a track segment is put into focus, three handles appear; one at each end of the segment
and one in the middle. Below are the actions that can be performed:
To re-position a segment “end”:
Place the cursor on one of the end handles
Click and release the left mouse button
Move cursor (and the attached vertex) to new location
Inserting a vertex in the track segment:
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Place the cursor on the middle handle
Click and release the left mouse button
Move the cursor (the vertex will move with the cursor)
Drag the track segment
Click on the track segment away from any handles
Drag the segment to a new location
More Track Editing Commands:
Re-route:
Select Edit » Move » Re-route from the menu
Click on a track segment and then re-route
Break:
Select Edit » Move » Break Track from the menu
Click on segment of track to insert a vertex
Drag End:
Select Edit » Move » Drag Track End from the menu
Click on an existing vertex then move it
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14.2.2 Pads

•

Place using the Place » Pad command or or the toolbar button shown above.

•

Pads are mainly used as part of components but can be used as individual objects such as
testpoints or mounting holes.

Figure 33 Via Properties dialog box

•

Pad properties are set in the Pad dialog box that is displayed by pressing the TAB key
while placing the pad or double-clicking on a placed pad. This dialog box has a Properties
tab, a Pad Stack tab and an Advanced tab. (See Figure 33) In the Properties tab you can set
the pad size, shape, hole size, layer and rotation.

•

If a pad is to have different sizes on the mid layers or bottom layer, check the Use Pad
Stack check box. This enables you to edit the Middle and Bottom properties in the Pad
Stack tab.

•

The Advanced tab allows you to assign a net to the pad, define the pad’s electrical type
(ie. load, terminator or source) and set whether or not the pad’s hole is plated. The NC
drilling software selects separate drill tools for plated an non-plated holes.
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Test Point Properties
Pads can be assigned as Top and/or Bottom Layer Testpoints
14.2.3 Vias

•

Vias can be placed using the Place » Via command or or the toolbar button shown above,
but they are normally placed automatically when you change layers while placing a track.
The auto-router also places vias.

•

Via properties are set in the Via dialog box which is displayed by pressing the TAB key
while placing a via or double-clicking on a placed via.

•

The via diameter, hole size and Start and Finish layers are set in the Via Properties dialog
box.

Figure 34 Via Properties dialog box

Setting the Start and Finish layers to any layers other than Top Layer and Bottom Layer
automatically assign the via as a Blind or Buried Via. Blind and Buried vias can be easily
identified as their hole is displayed as 2 half circles with different colours.
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Test Point Properties
Vias can be assigned as Top and/or Bottom Layer Testpoints
Solder Mask Section
Tenting
Checking the Tenting check box causes any Solder Mask settings in the design rules to be
ignored.
Override
Checking this check box allows you to override the Solder Mask setting in the design
rules by filling in the required expansion in the field provided.

14.2.4 Strings

•

Place using the Place » String command or or the toolbar button shown above. A String is
a single line of text.

•

String properties are set in the String dialog box that is displayed by pressing the TAB key
while placing a string or double-clicking on a placed string.

•

The actual text string to be placed is entered in the Text field.

•

Note that the text field is a drop down box, click on the down arrow to select from the list
of Special Strings that can be placed.
•

When a string is in focus, it displays a small
cross at its placement point and a small circle
at its right hand end. Clicking on that circle
allows you to rotate the string by moving the
mouse.
Figure 35 String Properties dialog box
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To assist in producing manufacturing documentation, the following Special Strings are
provided:
Special String

Description

.ARC_COUNT

Number of arcs in the file

.COMPONENT_COUNT

Number of components in the file

.FILL_COUNT

Number of area fills in the file

.HOLE_COUNT

Number of holes in the file

.LAYER_NAME

Name of the layer

.LEGEND

Drill symbol legend (place on Drill Guide layer)

.NET_COUNT

Number of nets in the file

.PAD_COUNT

Number of pads in the file

.PCB_FILE_NAME

PCB filename with full path

.PCB_FILE_NAME_NO_PATH

PCB filename

.PLOT_FILE_NAME

Plot filename

.PRINT_DATE

Current date when the layer is printed.

.PRINT_Scale

Scale the drawing is plotted at

.PRINT_TIME

Current time

.STRING_COUNT

Number of strings in the file

.TRACK_COUNT

Number of tracks in the file

.VIA_COUNT

Number of vias in the file

Table 15 PCB Editor Special String

Figure 36 Placing Special Strings

You place a special string using the Place » String command, but instead of filling in the Text
field in the Change String dialog box, you press the down arrow on the text field. This
displays a drop down box listing the special strings as shown. Select the desired special string
and press OK to place it.
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14.2.5 Fills

•

A Fill is placed using the Place » Fill command or the toolbar button shown above.

•

The Fill object is a solid rectangle and can be placed on any layer.

•

To place Fill, the first click defines a corner of the fill and then the next click defines the
opposite corner of the fill.

•

Fill properties are set in the Fill dialog box that is displayed by pressing the TAB key
while placing a fill or double-clicking on a fill.

•

When a fill is put in focus, you can change its size by clicking and dragging its handles and
you can rotate it by clicking on the small circle

Figure 37Fill Properties dialog box
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14.2.6 Arcs

The table below lists the Arc placement options:
Place Menu Command

Placement Toolbar

Arc (Edge)
Arc (Centre)
Arc (Any Angle)
Full Circle
Table 16 Arc Placment Commands

•

All of the above commands result in an Arc object being placed.

•

An Arc can be placed on any layer.

•

Arc properties are set in the Arc dialog box that is displayed by pressing the TAB key
while placing an Arc or double-clicking on a placed Arc.

Figure 38 Arc Properties dialog box
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14.2.7 Keepout Objects

Tracks, Fills and Arcs can be defined as layer specific keepouts by setting their keepout
property. They can be used to assign an area on a specific layer to be free of tracks and
components.
A keepout can be defined using the commands in the Place » Keepout menu that is also
defined as a pop up menu assigned to the K short cut key.
Objects defined as keepout display with a coloured band around them and are ignored by
output operations such as photoplotting and printing.
14.2.8 Room Definition

A Room Definition object is a rectangular region defining where components must be kept in
or kept out of.
Components can be assigned to a Room Definition by:
•

Designator

•

Component Class

•

Footprint

A Room Definition can either be assigned to Keep Objects Inside or to Keep Objects Outside.
A Room Definition object’s properties can be assigned in the Design Rules or by doubleclicking on the object.
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15 Cross Probing
Cross Probing is a powerful searching tool to help you locate objects in other editors by
selecting the object in the current editor.
Cross Probing is initiated by selecting the toolbar button shown above. You then select the
object to be located. When the object is selected, it is searched for in all other editors with files
open. If the object is located, its is displayed in the centre of the workspace in the case of the
PCB editor or the Schematic editor, or the object name is selected in the case of the Text
editor or the Spreadsheet editor.
The default settings for the cross probe command in the Schematic do not automatically
switch from the Schematic Editor to another editor.
To facilitate automatic switching from the Schematic Editor to another editor add the line
listed below to the parameter field of the Cross Probe toolbar command.
FocusWindows = True | Repeat = False
In the Schematic and PCB editor, you select objects by clicking on them. In the Text editor
and Spreadsheet editors you select text and then choose the Cross probe command. The
following applies:
Object Type Selected

Action in Other Editors

Text

Searches for that text

Text containing - (eg. U1-1)

Searches for a pad

Text containing a comma (eg. 5.05,1.05)

Searched for a co-ordinate

Table 17 Cross Probing Summary

Exercise
1. Open the documents Z80 Microprocessor.prj and Z80 Processor Board.pcb in Z80
Microprocessor.ddb.
2. In the Schematic editor execute the command Reports » Bill of Materials to run the Bill of
Materials editor.
3. Choose Next in each form that displays until you reach the form where you select the
report format. At this form check the Protel Format and Spreadsheet options and then
choose Next and Finish.
4. In the Spreadsheet editor, click in the cell for C5
and then press the Cross Probe toolbar button .
5. Switch to each of the editors currently open that C5 has been located in each of then.
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16 Using the Help System
16.1 Help Menu
A list of help options becomes available when you click on the Help menu. The options vary
between editors but Contents is always the first option and displays the Protel Help window
shown in Figure 39.

Figure 39 Help System Main Window
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Clicking on the Contents, Index or Find buttons at the
top of the Protel Help window displays the Protel Help
Contents panel (see Figure 40). The button you click
on will determine which tab at the bottom of this panel
is active i.e. Contents, Find, Index.
The Protel Help Contents panel tabs are described
below:

Figure 40 Help System Contents Window

Tab

Description

Contents

Displays Help topics in the order they are arranged in the Help documents

Index

Allows you to search for Help topics using index keywords

Find

Allows you to search for Help topics by any word
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16.2 Help Adviser
Clicking on the “?” icon at the right hand end of the
Status bar starts the Help Adviser shown in Figure
41. This allows you to query the Help system by
asking questions in normal conversational English.
Include a noun and a verb to give the best result.
Figure 41 Natural Language Help Advisor

17 Using the Protel Web Site
The Protel Web site is located at www.protel.com.
Here you can obtain information about Protel’s products and services, including access to
technical information and Service Packs. It is a good practice to regularly visit this Web Site.
•

Click on the Support option at the top of Protel’s Home Page to display the Support page.

• The Knowledge Base and FAQ’s are two of the options available on the Support page.
Knowledge Base
A search engine is provided to search the knowledge Base by product, version and date.
General Tips for Searching the Knowledge Base
•

Look for words with the same prefix e.g. enter Print* and you will locate print, printer,
printed, printing and so on.

•

Search for all forms of a word e.g. type sink** to find sink, sinking, sank and sunk

•

Search with the key NEAR for multiple word searches e.g. type schematic NEAR part to
look for the words schematic and part on the same page.

•

Refine your queries with the AND NOT keywords to exclude certain text from your search
e.g. to find all entries of components but not the page containing the text “off regularly”
write : components ANDNOT “off regularly”

•

Add the OR keyword to find all instances of either one word or another

•

Put quotation marks around keywords if you want to search for the complete phrase.

Report Form
If the information you require is not available you will be prompted to fill out and submit a
report form.
FAQS
Choosing the FAQS option displays a list of answers to frequently asked questions.
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